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1 Overview

Virtual prototyping is a method in the process of product development, which allows to
validate a design before making a physical prototype. Since V17.2, PSpice offers the
opportunity to simulate System Designs using different kind of abstractions thanks to the
Device Modeling Interface. With GUI, users can define C/C++, SystemC, and Verilog-A
components and simulate them in simulator.

1.1 Contents of this document

How to use Device Modeling Interface.

Setup for Visual Studio Community 2013.

How to integrate C/C++, SystemC and Verilog-A models to be simulated in PSpice.
Debug of C/C++, SystemC and VerilogA devices.

Importation of MATLAB Blocks in PSpice.

Hardware in the Loop using Arduino.

1.2 How to use this AN?

This document explains the steps for integrating C/C++, SystemC and Verilog-A models with
PSpice Device Model Interface (DMI), so that they can be used for PSpice simulations.

This document is valid up Release 17.2. License required for:
a. PSpice DMI — Model development capability:

e OrCAD PSpice Designer OR
e OrCAD PSpice Designer Plus OR
e Allegro PSpice Simulator

b. PSpice DMI — Model Simulation capability:

e OrCAD PSpice Designer Plus OR
e Allegro PSpice Simulator

Examples available:

Digital Power Supply using C/C++ defined PWM.
FIR Filter using SystemC.

Capacitor behavior analysis defined with Verilog-A.
Noise Filter using a MATLAB Block.

Hardware in the Loop using Arduino.

The structure of the attached ZIP file is divided in 6 folders:
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Debugging

Digital Power Supply
FIR_Filter
Hardware_in_the_Loop
MATLAB_Block_Simulation
VerilogA_Capacitor

- Each folder at the same time is divided in two folders:

Complete

To_be_completed

- You will work with the folder called “To_be_completed”.
- In each example the reference <directory> is used. It means the directory where you
place this ZIP File.

NOTE: You can find more specific information clicking on Start > All Programs - Cadence
Release 17.2-2016 > Documentation - Cadence Help. Search for the next documents:

- pspDMIRef

o Information about the functions exposed by PSpice Engine and by the DLL
files.

- pspcref

o Information about the meaning of the different parameters you can define for
DMI components.
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2 Device Modeling Interface Template Code
Generator

2.1 Required Software and Setup

This module covers the information on the setup required for compilation of C/C++, SystemC
and Verilog-A models in PSpice.

e SYSTEMC is an environment Variable you need to use if you want to define SystemC

components. For that, setup SYSTEMC environment variable pointing to the
SystemC installation path.

Systemvariable bearbeiten X

Name der Variablen: SYSTEMC

Wert der Variablen:  C:\Cadence\SPB_17.2\tools\pspice\tclscrip

OK Abbrechen ‘

%CDSROOT%\tools\pspice\tclscripts\pspModelCreate\SystemC

e.g.

C:\Cadence\SPB_17.2\tools\pspice\tclscripts\pspModelCreate\SystemC
e Visual Studio Community 2013

It is a free software that you can download easily here:

https://www.visualstudio.com/en-us/news/vs2013-community-vs.aspx

You will be forwarded to Visual Studio Community 2013 Website. Click on Download
and install it.

Visual Studio Community 2013

November 12, 2014

Visual Studio Community 2013 is a new edition that enables you to unleash the full power of Visual Studio to develop cross-platform solutions. Create apps in

nt tools into this IDE. (These extensions are available

Download Visual Studio Community 2013.

After the installation, open the software and verify it works.

NOTE: It works with VS Express as well, but the project will not be generated
automatically.
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Dd Start Page - Microsoft Visual Studio
FILE EDIT VIEW DEBUG TEAM TOOLS TEST ANALYZE WINDOW  HELP

g - u

Start Page +# X

» Community 2013

XOQIoo)  Jaoidxg Janas

Start

Open Project...

Open from Source Control...

Recent

= P Attach.. -

Discover Visual Studio Community 2013

Get the most from Visual Studio with these resources: What's new on Microsoft Platf

Learn more about Azure

- 4 IJ’_""‘
Connect ()

n:an

Windows Phone

e Arduino IDE (Only in case you want to do Hardware in the Loop)

o You can download the software from Arduino Website.

o You also need the Hardware, specifically the Arduino Starter Kit.

2.2 How to use Device Modeling Interface?

Device Modeling Interface Template Code Generator can be launched from Model Editor in

PSpice Accessories.

Cadence Release 17.2-2016
g% License Client Configuration Utility

Allegro EDM Products

Allegro Products

Allegro Sigrity Products

Documentation

OrCAD Lite Products

OrCAD Products

Product Utilities

| PCB Editor Utilities

| . PSpice Utilities
Magnet%Parts Editor

EJ Model Editor

Simulation Manager
Stimulus Editor

Dolby

s oaa

m
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clicking on Model > DMI Template Code Generator.

Plot Tools Window Help

Copy From...
Add Smoke...

DMI Template Code Generator...
IBIS Translator...

Import...
Export...
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| | DMI Template Code Generator 25—
Use this dialog-box to auto-generate DMI template code for the following PSpice-DMI models: Analog, Digital, and
SystemC. The dialog-box also imports the Verilog-A Compact Device models using ADMS
Recommended steps:
1. Testthe model code stand-alone by building an exe
2. Create the PSpice-DMI adapter code, and edit itin Visual Studio to insert model code
3. Use the generated PSpice library ( lib file) to create a schematic symbol The generated symbol can be placed
in the schematic for PSpice simulation
Part Details -
Part Name customPart
Part Type Digital C/C++
Ports -
Interface Type Combinatorial
Port Entry Ports CSV File
Parameters
Global Parameters
Device Parameters
Output -
DLL File Name customPartdll
Log File Name customPartlog
DLL Location C\Users\rgandia. FC-EDA\DMIM | | Browse...
OK | Cancel | Help
PSpice DMI Template Generator

This interface is divided into 4 sections:
e Part Details:
o Part Name: Name for the function you want to define. For example, Pulse
Width Modulation.
o Part Type: Define the type of component you want to describe.

customPart

Digital C/C++ vg'

"Digital C/C++
SystemC

Analog
VerilogA-ADMS

e Ports:
o Interface Type: Classify your component as Clocked or as Combinatorial.
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'Combinatorial v '
Combinatorial {b
|Clocked

o Port Entry: Define the inputs and the outputs of your device through an excel
file or writing down them directly.

Port Entry

« Specify the port countfor Input and 10 Ports

e Specify Portsize for vector ports, default size is 1

« Initial values are used fto initialize ports in device constructor code
s CLK portis automatically created for Clocked interface type

Enter number of input ports 2
Enter number of IO ports 02
Port Name E Port Type Port Size Default Port Description
i : Value
Port0 Input 1 0
Port1 Input 1 0
Port2 10 1 0
Port3 10 1 0

e Parameters:
o Global Parameters: Parameters that can be used by all the components which

define them.

| Global Parameters

+ Specify the global parameters which will be used by the device logic.

» These parameters need to be defined in the top-level schematic - DMI model will
get their values from PSpice

« Defaultvalue will be used to initialize the parameters in device constructor code

Enter number of parameters 3

Parameter Name  Parameter Default Parameter Descri&on
Type Value

Param0 double 0

Param1 double 0

Param2 double 0

o Device Parameters: Parameters used just for a particular device.

Application Note
Virtual Prototyping in PSpice Page 8 of 80



FlowCAD

Application Note

Device Parameters

« Specify the Device parameters

Enter number of parameters

Parameter Name

Param0
Param1
Param2
Param3

Param4

Parameter
Type

double
double
double
double

double

Default
Value

0

o O O O

Parameter Descripfion

e OQutput: Define the name for your DLL, the log file where information of the generation
of the DLL is going to be written and the directory where it is going to be saved.
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3 Examples

3.1 Digital Power Supply using a C/C++ defined PWM

This module shows a Digital Power Supply design, which uses models with different levels of
abstraction.

This example demonstrates:
e The generation of template code for a DMI Model and the implementation of a Digital
PWM Control block.
e Simulation of the DMI model in the context of a Digital Power Supply circuit.

Steps:
1. Launch Model Editor
2. Select Menu Item Model - DMI Template Code Generator
3. Enter the data as follows:

# | DMI Template Code Generator &3

Use this dialog-box to auto-generate DMItemplate code for the following PSpice-DMI models: Analog, Digital, and
SystemC. The dialog-box also imports the Verilog-A Compact Device models using ADMS
Recommended steps:

1. Testthe model code stand-alone by building an exe

2. Create the PSpice-DMI adapter code, and edit itin Visual Studio to insert model code

3. Use the generated PSpice library (.lib file) to create a schematic symbol The generated symbol can be placed
in the schematic for PSpice simulation

Part Defails
PartName PWMControl
Part Type Digital C/C++
.Porls
Interface Type Clocked
Port Entry Ports CSV File
Parame!ers
Global Parameters
Device Parameters
Output
DLL File Name PWMControl dll
Log File Name PWMControl log
DLL Location D \PSpice\Application NotesFloy | Browse.
OK Cancel Help
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4. Click on CSV File to enter ports using a csv file

Interface Type

Port Entry

5. Browse to the csv file portsv.csv

You will find this file in

Clocked

Ports

CSVFile

<directory>\Circuits\Digital Power Supply\To_be_completed\Ports

Port Entry

+ The csvfile needs to follow the following syntax
<Port Name=, <Port Type: Input]lO=, <Port Size=, <Initial Value=, <Port Description=

« Forexample,

IN1, INPUT, 1, X, Input Port 1
OUT, 10, 8,0, 10 Port 1

Select your CSV file here DMNDigitalPowerSuppliportv.csv| Browse

Port Name Port Type Port Size
CLK INPUT 1
FB INPUT 8
REF INPUT 8
PW IO 1

Default Value Port Description

0

0
0
0

Clock

Feedback input
Reference input
Output Pulse Width

The ports are automatically read from the csv file and populated in the form as above.

6. Review the port list and click OK.

7. Enter Global parameters as shown below:
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Global Parameters

+ Specify the global parameters which will be used by the device logic.

+ These parameters need to be defined in the top-level schematic - DMI model will
get their values from PSpice

« Default value will be used to initialize the parameters in device constructor code.

Enter number of parameters 2

Parameter Name  Parameter Default Parameter Description
Type Value

PER double 0 Period

D double 0 i Duty Cycle

0K Cancel Apply

8. Click OK.
9. Before generating the whole files, browse to directory to locate them.

<directory>\Circuits\Digital Power Supply\To_be_completed\DMI_Code

NOTE: This file does not generate any DLL. The DLL will be generate it in Visual
Studio when the code is compiled.

10. Click OK and generate the files:

NOTE: A message might appear indicating that it could not be possible to find the lib.
This message can be clicked away and ignored.
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tran.out | cepDMl.net | coplib | ran.out | psposp™wiMContalh  pspPWMContiollog® |

+ Format Column Macro Advanced Window Help

Reading json
Json cead..Logging Nodel Creacion...
reading Model Neme and Type...
reading global and instsnce paramz for digital and analogy..
declaring the glohkal varisbles..
readiny instance parars..
declaring and defining instance params. ..
Copyinyg common files ..
Creating Digital Nodel...
Gecciny port 1nlIormation...
Initializing input port specific variables...
A\ capture\DESIGN1-FSpicefF bes\copCMIVoran)tran. it I‘w variables...
WEIT1NG POIT SPECIIIC Cooe 1m cpp ILile...
Changes Ln evaluate Iunctlion...
Digical/SystemC GUID creacion...
read lnput Ilile COII!IIICII'.TEII'IJ].&LE-":JS:J!JIU’THHU_I:IJU.EI.L‘DD
opensd output Iile [:/customsrs/Denmarki016/0K1/DigitalPowerSupply/Code//pSspEngfunc. cpp for vriting
read input Iile CommonTewplats/pspEngfunc_model.h
op=n=d output file [:/custom=cs/Denmarki016/IKI/DigitalPowsc3upply/Code//pspEngFunc.h for writing
read input file DigitalTemplate/papligitallode lNarwe.cpp
open=d output file [:/customers/Denmark2016/INI/DigitalPowerSupply/Code//peppspPiMConcrol.epp for writing
read input file DigitalTewplats/papdigitallode INare. h
opensd output file [:/customers/Denmark2016/INI/DigitalPowerSupply/Code//pesppspPWMControl.h for writing
read input file Iligital’l’e«plate!digi:almodel_user.epp
open=d output file D:/customers/Denmark2016/0N1/DigitalPowerSupply/Code//pspPUliControl _user.epp for writing
Populating veprol with the source and header files
read input Iile DigitalTemplace/Diglrallode IName.vexpro]
Lib created..

11. The new created files are located in a new folder called PWMControl. You can find
this folder in

<directory>\Circuits\Digital Power Supply\To_be_completed\DMI_Code

In this folder, the created files are organized in two folders:

| code
L lib

In code you will find the Visual Studio project files. With them you will generate the
DLL:

[3 pspEngFunc.cpp
[y pspEngFunc.h
[ pSpiceBase.h
[ PSpiceCMIApiDefs.h
[ PSpiceCommonAPIDefsh
[ PSpiceDigApiDefs.h
L pspPWMControl.cpp
[ pspPWMControl.h

| PWMControl.log
=) PWMControl.vexproj
[3 PWMControl_user.cpp
[3 stdAfx.cpp
[ StdAfxh

In lib you will find the PSpice Model (PWMControl.lib).
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Model Name Type Mod
%_PWMControl SUBCXT

Lsubckt Z_PulControl CLK FB O FE 1 FB 2 FB_ 3 FB 4 F3 S FB_6 FB_7 REF_O
REF_1 REF_2 REF_3 REF_4 REF_S REF_6 REF_7 PU

+ OPTIONAL: DPWR=$G_DPWR DGND=$G_DGND

+ PARAMS:

.model PUMControl TIMING ugate (

+ tplhmn=6ns tplhty=9ns tplhmx=15ns

+ tphlmn=6ns tphlty=10ns tphlmx=15ns

+ )

Ul LOGICEXP( 17, 1 ) DPWR DGND

+ CLE FBO FB 1 FB 2 FB 3 FBE 4 FB 5 FB 6 FB 7 REF O REF 1 REF 2 REF 3
REF_4 REF_S REF 6 REF 7 pW  —  ° B N B -
+ PWRControl TIMING IO STD

+ C_HODEL: PUMControl.dll PWMControl

+ PARAMS:

.ends

Note: The generated model already points to the PSpice-DMI dil PWMControl.dll,
although it still has to be generated — For that, the next step is to describe the model
code and generate the dll.

12. Launch Visual Studio Community 2013
13. Click File> Open-> Project/Solution

Search for PWMControl.vexproj located in:

<directory>\Circuits\DigitalPowerSupply\To_be_completed\DMI_Code\PWMControl\c

ode

E U View

B-2

UtBUG

o

TEAM  JUAAS  desd

- | P Attach... =

AMNALYLE  WINUOW

HELH

Team Explorer - Connect Start Page ® X

P Community 2013

Get th

Open from Source Coentrol...

Disges

Aiesaal Tl Cemeena amih e 3T D
o Open Project ]
@.P_\ \_)' « Circuits » Digital Porwer Supply » Completed » V5_Code v 42| v5.Code durchsuchen 21 jat's n
Qrganisieren = Neuer Ordner finde
4 Musik “ Name 2 Anderungsdatum  Typ i
& OneDrive — Winde
L3 PwMControlvexproj 13.06.2016 16:29 VC++ Project g kg  [Windo

<p Zuletzt besucht

o Bibliotheken
. Bilder

°» Dokumente =
4. Musik

B videos

A Computer
&= Windows7_OS (C)
« Datal (Dr)
& support (\dc01) { ~ «

Dateiname: = | All Project Files (*sin*.dsw;* =

Offnen Abbrechen

14. Change the default configuration on the top to Release x64
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TEST

=

AMNALYZE WINDOW HELP

-

x64

-|| 5

~ | Release

and Build the solution to verify that there are no build issues.

ECT | BUILD A DEBUG TEAM TOOLS TEST ANALYZE WINDOW
# | | & Bsuild Solution Ctrl+Shift+B - | x64
. Rebuild Solution
Clean Solution I
Run Code Analysis on Solution Alt+F11
@ [ &8 Build PWMControl
Rebuild PWMControl
o Clean PWMControl
Project Only 4
:nden Profile Guided Optimization ’
pp :
Batch Build...
Configuration Manager...
iDefs, e +F7
ONAPlersr
Defs.h
rol.cpp
Output
Show output from: | Build - <= |

I
1>
1>
1>
1>
1>
1>
1>
memnsssm== Bujld: 1 succeeded,

pspEngFunc. cpp
pspPWMControl. cpp
PWMControl_user.cpp
StdAfx.cpp

Generating code
Finished generating code

Build started: Project: PWMControl, Configuration: Release x64

Creating library D:\PSpice\Application Notes\FlowCAD_AN_Device_Modeling_Interface\Circuits\Digital Porwer Supply\Compl

PWMControl.vcxproj -» D:\PSpice\Application Notes\FlowCAD_AN_Device_Modeling_Interface\Circuits\Digital Porwer Supply\Com

@ failed, @ up-to-date, @ skipped ====ssm===

15. Edit the file PWMControl_user.cpp

16. Go to evaluate function by searching for the text “pspPWMControl::evaluate”. Now,
search for “// LOGIC TO BE IMPLEMENTED BY USER”

This is the place where you will add the model evaluation code.

17. Open the file COPY.TXT located in

<directory>\Circuits\DigitalPowerSupply\To_be_completed\DMI_Code

Application Note
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copy the code that there is inside and paste it just after /LOGIC TO BE
IMPLEMENTED BY USER.
// LOGIC TO BE IMPLEMENTED BY USER
oldPW = PW;
pspBits2Int(FB, FBInt, 8);
pspBits2Int(REF, REFInt, 8);

if (REFInt > FBInt && mD < ©.98) {

mD += ©.81;
¥
else if (REFInt < FBInt && mD > ©.02) {

mD -= 0.01;

[//fprintf(stderr, "Reducing DutyCycle\n");
}

if (mCurrentCLKCount <= @) {
mCurrentCLKCount = mPER;

}

if (mCurrentCLKCount > mD * mPER)
mPWStatus = false;

else
mPWStatus = true;

if (mPWStatus == true && (int)PW != 1){
PW = pspBit::HI

¥

else if (mPWStatus == false && (int)PW != 0){
PW = pspBit::L0;

¥

mCurrentCLKCount--;
fprintf(stderr, "FBInt=%d REFInt=%d mDutyCycle=%g PW=%d\n", FBInt, REFInt, mD, (int)PW);

18. Save the project.

19. This code uses some extra variables which need to be declared — edit file
pspPWMControl.h and add the following lines at the end before the last closing
brace.

Application Note
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vV T DSPHEWITRLONCron.Cpp

b B pspPWMControl.h

b *+ PWMControl_user.cpp
*+ StdAfx.cpp

b B stdafx.h

[ AR RS EAE R R R

/xltxxxtxxtxxttxxz ...... txExeE ]

/* Global params description
PER: Period
D: Duty Cycle

- J

/

double mPER;

srirersarirersurerey
.
H

double mD;
Jrrnnmn s ssssssnnes P /
= /* Instance params description
=/
/tlllbbt...lllsb...'llllt...'llll.’
/lli-ll- ----- EERREEREERES EEEEEES /
= /* Port Description
Input CLK : Clock
Input FB : Feedback input
Input REF : Reference input
Output PW : Output Pulse Width
|
/-ltxxxt- xxxxx EEEEEEEEESE x--tx-l.’(
yspBit prevCLK;
unsigned int CLKint,FBint,REFint,PWint;
‘‘‘‘‘ %...FBL81, REF[8],, CLK,, Pu, oldPw;
unsigned int FBInt, REFInt;
int mCurrentCLKCount; :
bool mPWStatus; :
sissnenrensustssnsrstncusersrel
I
#endif

20. Build the solution again. The model dll is now built with the required model evaluation

code.

BUILD | DEBUG

Fe

TEAM
Build Solution
Rebuild Solution
Clean Solution

Run Code Analysis on Solution
Build PWMControl

Rebuild PWMControl

Clean PWMControl

Project Only

Profile Guided Optimization
Batch Build...

Configuration Manager...

Compile

TOOLS

s

TEST  ANALYZE
Ctrl+Shift+B  }

Alt+F11
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Output

Show output from: | Build

1> pspEngFunc.cpp
1> pspPWMControl.cpp
1> PWMControl_user.cpp

1> StdAfx.cpp

1> Generating code
1> Finished generating code

NOTE: Do not consider the warning.

21.Goto

||

1y------ Rebuild All started: Project: PWMControl, Configuration: Release x64 -----

1>PWMControl_user.cpp(160): warning C4244: '=" : conversion from 'double’ to 'int’,

1> Creating library D:\PSpice\Application Notes\FlowCAD_AN_Device_Modeling_Intei

1> PWMControl.vcxproj -» D:\PSpice\Application Notes\FlowCAD_AN_Device_Modeling_Im
========== Rebuild All: 1 succeeded, @ failed, @ skipped ==========

<directory>\Circuits\DigitalPowerSupply\To_be_completed\DMI_Code\PWMControl\c

ode\x64\Release

and verify that the DLL and the PDB has been generated:

. PWMControl.tlog
ﬁ: pspEngFunc.obj
ﬁ.‘: pspPWMControl.obj
! PWMControl.Build.CppClean.log
! PWMControl.dll
PWMControl.exp
2] PWMControl.lib
! PWMControl.log
& PWMControl.pdb
z PWMControl_user.obj
%% StdAfx.obj
& vc120.pdb

22. Open OrCAD Capture and click File> Open-> Project.
23. Open the Capture project located in

<directory>Circuits/Digital_Power_Suppy/To_be_completed/circuit/Power_Supply_inc

omplete.dsn:
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L4
VIN Ay VOUT

PARAMETERS: [ AT
FER =10
D=02

E n E N D4

@ @

MUR150
N Software Controlled Switch
S0vde ::::\-"32 GND
< Rload
I =
& 3 ® = 50
| | uz
1 X b
OUTPUTINPUT b
| CLK NOISECOMP
| ovm
il N I .
BT i = u —]
<] “pE Ay = S

| STARTVAL =0

; OPPVAL =1

l

=0

Click on the component Software Controlled Switch with RMB and click on Descend
Hierarchy:

Edit Properties...

Edit Part

Export FPGA

Descend Hierarchy N

Connect to Bus
User Assigned Reference  »

Now you have to create the Symbol for the PSpice component you have just
described: PWM Block

Software-Controlled

PWM Block
B —

= = SW1
FES — N
U4 2%
: : = e omven |
MATLAS_AVGFILTER q
MATLAB Algorithmic Block —= IRF40
SW2
=0 ,
DEML_  aDC_CLk 2| Comverser Treg
al
Sampling Freq
&
5
ADCEbs
ui e
REF . [} 1w BT :g :,ﬁ'-_'
2 "I‘-":.E’: AL TEFS
C Kii'd L 2] vge
T & = i vee
» LA -
1 4 DB2 o REF ?\-"
O OVERE! |y =EFD
2 ner % . BV =¥ %
socsemT— Analog to Digital T
|  Convertor 8] ~o
o
ax - [}

24. Open Model Editor and click on Done.
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Select Design Entry Tool =2
Choose Default Design Entry Tool
(") Design Entry HDL

(@) Capture

["|pon't ask me again.

25. Click on File > Open and look for PWMControl.lib

<directory>\Circuits\DigitalPowerSupply\To_be_completed\DMI_Code\PWMControl\li

b

26. Click on File = Export to part library and click OK.

Create Parts for Library =

Enter Input Model Librany:
Parwer SupphACompletediLibrary_Rob\PWhControl lib Browse...

Enter Output Part Library:
“orwer SupphACompletediLibrary_Rob\PvhControl.olb Browse...

[ ok | [ cancel | [ Hep |

With this option you are creating the schematic part for this PSpice component

automatically:

! PWMControl.err
PWMControl.lib
PWMCONTROL.OLB

@

3

27. Come back to the Schematic and place the symbol you have just created, modifying

this symbol as seen below or using the one from

<directory>\Circuits\Digital Power Supply\To_be_completed\Library\Capture

L T e ]

0402CS-19N/COILCRAFT o |

C'x

Add Library (Alt+A)

Libraries:

Parts per Pkg: 1

‘ ‘ Packaging

Part: -
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28. Place the symbol and connect it in the circuit:

FBO
FB1

FBZ 4

FB3

FB4 6

FBS

FB6

—__FBY

2
3

5

7
8
]

10

1"

12

14
15
16
ir

Software-Controlled

PWM Block

X_PWMCONTR

PSpict
Behavi

o —| N
o3 e
FB_6 18
FB_7 PW GAT

Convertor Freg

29. Define a Transient Analysis Simulation and call it Trans:

New Simulation Profile k

R ORE 84 8 4«

AGET [ Wi

New Simulation &3
MName:
Trans
[ Cancel l
Inherit From:
none v] L
Root Schematic.  SCHEMATICT

30. Define Run to Time = 5ms
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gﬁﬂ Simulation Settings - Trans 53

General | Analysis | Configuration Files | Options | Data Collection [ Probe Window

Analysis type:

i 5
[Time Domain (Transient) _'_J Fun to time: ms seconds (TSTOF)
Options: Start saving data after: JU seconds
DIGerlelﬂ i Transient options
_IMonte Carlo/Worst Case Maximurm step size: seconds

_|Parametric Sweep
_| Temperature (Sweep)
_]Save Bias Point

[ILoad Bias Point [ Runinresume mode Output File Options.
_|Save Check Points

[ Skip the initial transient bias point calculation (SKIPEP)

_IRestart Simulation

31. Click on Configuration Files. You have to import the PSpice model for the component
you have just created and the already defined ones. Click on Browse, select one by
one and click on Add to Design.

You will find your library PWMControl.lib in:

<directory>/Circuits/DigitalPowerSupply/To_be_completed/DMI_Code/PWMControl/li
b

You will find the other libraries in
<directory>/Circuits/Digital Power Supply/To_be_completed/Library/Capture:

a. Noisecomp.lib
b. Matlab1.lib

c. Matlab.lib
&8 simulation Settings - Trans &3
| General | Analysis [ Configuration Files Options | Data Collection | Probe Window
] Details
Cakgon Filename:
Stimulus | Browse...
Include Configured Files =l = =
U - -
[v Update Index m.\ll.brary\pwmconuol.l.m Add as Global
&3] Mibrary\noisecomp.lib

\library\matlab1.lib Add to Design
\library\matlab.lib
@nomlib Add to Profile
Edit
Change

Library Path

|"C.\Ca dence\SPB_17.2\tools\PSpice\Library" Browse...

0K H Abbrechen | | Ubemehme | Hilfe ‘
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32. Before running the simulation, do NOT forget to associate all the .DLL’s, which
describe the behaviour of your components. For that, place the .DLL and the .PDB in
the Simulation Profile Folder that you have just created:

<directory>\Circuits\DigitalPowerSupply\To_be_Completed\circuit\Power_Supply_Un
complete-PSpiceFiles\SCHEMATIC1\Trans

NOTE:

Your created .DLL is in:
<directory>/Circuits/DigitalPowerSupply/To_be_completed/DMI_Code/PWMControl/c
ode/x64/Release

PWMControl.tlog

4?} pspEngFunc.obj

43 pspPWMControl.obj
PWMControl.Build.CppClean.log
PWMControl.dll
PWMControl.exp

=| PWMControl.lib
PWMControl.log

& PWMControl.pdb

43,' PWMControl_user.obj

% StdAfx.obj

& vc120.pdb

The other one is in:
<directory>/Circuits/DigitalPowerSupply/To_be_completed/Library/DLL

NOTE: There is another option to store your created DLL's and PDB’s using an
Environment Variable. It allows you to use a central library for all your DLL’s.

Systemvariable bearbeiten &3

Name der Variablen: CDN_PSPICE_MODEL_PATH

Wert der Variablen:  'e_Modeling_Interface\Circuits\DLL_Library

0K . Abbrechen ‘

In this Application Note however, where are placing them in the Simulation Profile
Folder.

33. Click on Run:
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=

1|8

Run P

»_PWMCONTRC
8R4

DICe

-~
=
L

34. Analyze the results. Click on PSpice - Markers > Voltage Level and place it in the

node called VOUT.

m Accessories Options Window Help

. & New Simulation Profile
Edit Simulation Profile
5
¥ ©Run
View Simulation Results
View Output File
= Create Netlist
View Netlist
Advanced Analysis

Markers
Bias Points

EaYtQ@

#3 Voltage Level
» | 4 Voltage Differentidl

PARAMETERS
ER = |
D=02

50Vde ﬁ:‘asz

L4

[ 3
[T Talal

#8 Current Into Pin
A8 Power Dissipation
Advanced »

Plot Window Templates...
Show All
Hide All

Delete All
List...

4TuH

1150

1 <
= OUTPUINPUT

NOISECOMP

22

You will be able to see this results in the Probe Window:
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35. In Probe Window click on Plot - Add plot to Window.

ce Buleid Tools Window Help %

Axis Settings... ns

Add Y Axis STRG+Y
= ¥

Add Plot to Window [}
Delete Plot
Unsynchronize X Axis

Label B

v Transient

36. Go to OrCAD Capture again, and place another Voltage Marker in the wire called
PW:

us

— = IN GATE
GND REF

GATE_DRIVER

w

IRFE40
M1

MCONTRQL

or Freq

37. Visualize the results in the Probe Window:
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NOTE: In this case everything has worked perfectly, but most times it is necessary to
debug for detecting error and mistakes in the source code description. More information
in section 3.3.

3.2 FIR Filter using SystemC

This module explains definition and simulation of a SystemC model using PSpice-DMI.

It demonstrates:
- An example of a FIR model written in SystemC.
- Generation of DMI Template code for SystemC models using Model Editor.

Steps:
1. Launch Model Editor

2. Select Menu Item Tools/DMI Template Generator
3. Enter data as below:
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(@] DMI Template Code Generator LX "l

Use this dialog-box to auto-generate DMI template code for the following PSpice-DMI models: Analog, Digital, and
SystemC. The dialog-box also imports the Verilog-A Compact Device models using ADMS.
Recommended steps:

1. Testthe model code stand-alone by building an exe.

2. Create the PSpice-DMI adapter code, and edit itin Visual Studio to insert model code.

3. Use the generated PSpice library (.lib file) to create a schematic symbol. The generated symbol can be placed
in the schematic for PSpice simulation.

Part Details
PartName FIR
Part Type SystemC
Ports
Interface Type Clocked
Port Entry Ports CSV File
Parameters
Global Parameters [ _'
Device Parameters |
. Qutput
DLL File Name FIR.dIl
Log File Name FIR.log
DLL Location D:\PSpice\Application Notes\Flo \ Browse... _'

oK || Cancel || Help |

PSpice DMI Template Generator

DLL Location: <directory>\Circuits\FIR_Filter\To_be_completed\DMI_Code
Do not click OK.

4. Click on Ports radio button to enter the following port data:
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Port Entry X
« Specify the port countfor Input and 10 Ports.
e Specify Port size for vector ports, default size is 1.
« Initial values are used to initialize ports in device constructor code
e CLK port is automatically created for Clocked interface type.
Enter number of input ports 2
Enter number of IO ports 1
Port Name Port Type Port Size Default Port Description
Value
CLK Input 1 0 Clock Port
input Input 16 0
e, 1
oufput IO 116 10

5. Click OK to close the Port Entry and click OK to generate the code.

6. The PSpice library for the generated model is created automatically. The vector ports

are expanded to PSpice-supported scalar ports in the lib file:

M_Zl .subckt X FIR CLK input_0O input_1 input_2 input_3 input_4 input_5 input_
Model Name m Modil| | 6 input_7 input_8 input_$S input_10 input_11 input_12 input_13 input_14
%_FIR SUBCKT input_lS nutput_D output_l output_z outpuc_a oucput_q outpuc_S output_ﬁ

output_14 output_15

+ OPTICNAL: DPUR'sG_DPUR DGND'SG_DGND
+ PARAMS:

.model FIR_TIMING ugate |

+ tplhmn=6ns tplhty=9ns tplhmx=15ns
+ tphlmn=6ns tphlty=10ns tphlmx=15ns
+ ]

Ul LOGICEXP( 17, 16 ) DPWR DGND

output_15

+ FIR_TIMING IO_STD

+ C_MODEL: FIR.dll FIR
+ PARANS:

.ends

I

output_7 output_8 output_9 output_10 output_11 output_12 output_13

+ CLE input_ﬂ input_l inpur._z input_3 inpu\:_4 input._S input_s inpur._'?
input_8 input_9 input_10 input_11 input_12 input_13 input_14 input_15
output_0 output_1 output_2 output_3 output_4 output_S5 output_6 output 7
output_B nutpu\:_Q output_ltl output_ll nutput'._lz out.pul:_13 ou\:put_14

This library points to the PSpice-DMI dll FIR.dIl — The next step is to complete the

model code and generate this dll.
7. Launch Visual Studio Community 2013 and click on Open Project.

Select

<directory>\Circuits\FIR_Filter\To_be_completed\DMI_Code\FIR\code\pspSysCFIR.v

CXproj

8. Change the default configuration on the top to Release x64, and Build the solution to

verify that there are no build issues.

NOTE: There are many warnings, but you can omit them.
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9. Edit SysCFIR.cpp

-'void SysCFIR::entry() {

=1//
//
//
//
//
//
//
//
//
//
//
//
i
//
//
i
//
//
i
/!
//
//
}

const sc_uint<8> coef[5] = { 18

107, 77, 18 };

.

sc_int<16> taps[5];
output.write(0);
wait();

while (true) {

—

for (int 1 = 4; 1 > @; i--) {
taps[i] = taps[i - 1];

}

taps[@] = input.read();

sc_int<16> value;

for (int 1 =0; 1 < 5; i++) {
value += coef[i] * taps[i];

1

s

output.write(value);

FILE* fp = fopen("out.vcd", "a");
fprintf(fp, "\n%d %d %d", value);
fclose(fp);
cout << "Time["
wait();

<< sc_time_stamp() << "] Value[@x"<< he

Search for SysCFIR::entry function in SysCFIR.cpp and uncomment the sample code
inside the function clicking on Edit - Advanced - Uncomment. This code
implements an FIR filter using SystemC.

10. Edit pspSysCFIR.cpp:

pspSysCFIR: :pspSysCFIR(const char* pInstName, void*pRef){
mRef = pRef;
mInstName = pInstName;
mPortCount = 33;
mInputPortCount = 17;

m_SysCFIR = new SysCFIR(pInstName);
m_SysCFIR->CLK(sysCsig CLK);
|m_5ySCFIR—>Peset(sysCsig_PeSet)j| <-Add it
m_SysCFIR->input(sysCsig_input};

m_SysCFIR->output(sysCsig_output);

H

11. Build the solution again to generate the PSpice-DMI dll.

12. Open Model Editor from PSpice Accessories, click File> Open and load FIR.lib from

<directory>\Circuits\FIR_Filter\To_be_completed\DMI_Code\FIR\lib

13. Click File > Export to Part Library and click OK.
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Create Parts for Library &3

Enter Input Model Library:

Enter Output Part Librany:
2\Circuits\FIR_Filte\Complete\DMI_Code\FIRYib\FIR.olb Browse...

[ ok | Cancel | [ Help ]

14. Copy FIR.lib and FIR.olb files and paste them in
<directory>\Circuits\FIR_Filter\To_be_completed\Circuit\Library

15. Launch OrCAD Capture and open the project located in
<directory>\Circuits\FIR_Filter\To_be_Completed\Circuit

OFFTIME=Im | cix
ONTIME =1m  E=rr CLK
DELAY =

STARTVAL =0

CFFVAL =1

EP3pice:

T_DETML STIM(1E,4444) %G DEWH $5_DEND
+ IND INL INZ IN4 IN4 ING IN6 INT INE ING
+ THLO IN11 INLZ IN13 IN14 IN1S

+ T0_STM IO_LEVEL=0

+ 0 BOO0

+REFEAT FOREVER

+ +Ims AECT

+ +Zms DAEC

+ +Ims CORE

+ +Zms ECDA

+ +Im= AECT

+ ENDEEPEAT

AT

A
5

16. Click on Add Library, select FIR.olb and place the FIR component:

OFFTIME = 1m U -CLK N o1
T =1 CL
gLvs T B = T oK DUTFUT 0
STARTVAL =0 TIHT = | INFUT_D OUTPUT_1
OFPVAL = 1 —IHF & | INFUT_1 SUTPUT_2
—IHZ & | INPUT_Z OUTPUT_3
—IH§ & | INFUT_2 OUTPUT_#
TIRE 7| INFUT_4 OUTPUT_&
—E—=| INFUT & OUTFUT &
—T—= INFUT & SUTFUT
i r | IMPUT. OUTPUT_&
EPSpice: _THE T ~ ! _
U_DSTM1 STIM(1E, 3444) $&_DEWH $6_DEND TIRE 1T | INFLUT 2 OUTFUT_ = 0
+ THD N1 THZ TH2 IN4 THG IWE IN7 IHE THD — NI 12 | INFUT 3 QUTRUT_10 g7
+ INL0 IN11 IN1Z IN13 IN14 INLS — T T | INPUT_1D SUTFUT_M [Far— i —
+ TO_STM IO _LEVEL=0 TIHIE & | INPUT_11 OUTRUT 12 ar—oi3
+ 0 0000 IR TE | INPUT_12 OUTPUT_'2 Faz— g
HREEERT FCREVER — T INPUT 13 - OUTPUT 14 i3 —
e e —RTE—T| INFUT 14 OUTPUT_ 15 ————
+ +iz= [REC ———— INPUT_15 B
+ +im= CDRE _
+ +2m= BCIA
+ +Em= AECD ¥_FIR:
+ ENDREPEAT

17. Create a new Simulation Profile called Trans.
18. Complete the new Simulation Settings with this values:
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@ Simulation Settings - Trans

[R]

'. General_l Analysis | Configuration Files | Options ] Data Collection ] Probe Window:

Analysis type:
|TimeDomain(Transient} :_J

Options:

@ General Seltings

[IMonte Carlo/Worst Case
[]Parametric Sweep
[1Temperature (Sweep)
[1Save Bias Point

[Load Bias Point

[]Save Check Points
[|Restart Simulation

Run to time:

W seconds (TSTOP)
IIJ seconds
Transient options

Maximum step size: seconds

[ Skip the initial transient bias point calculation (SKIPEP)

Start saving data after:

[ Run in resume mode Output File Options...

l OK H Abbrechen ] Jbernehmen

19. Click on Configuration Files and add to Design the library you have just created:

ﬂ Simulation Settings - Trans

| General 1 Analysis | Configuration Files iOpIions Data Collection | Probe Window|

. Details
Category: Filename:

&

Stimulus [
Include Configured Files

Browse...
Xl = =

[v Update Index
@nomlib

4 L]

Library Path

\library\capture!fir lib

Add as Global
Add to Profile
Edit
Change

"C\Cadence\SPB_17.2\tools\PSpice\Library"

20. Copy the DLL from

Browse...

0K l[ Abbrechen ] Ubernehmen Hilfe

<directory>/Circuits/FIR_Filter/To_be_completed/DMI_Code/FIR/code/x64/Release

And copy it in

<directory>/Circuits/FIR_Filter/To_be_completed/Circuit/FIR_Filter-
PSpiceFiles/'SCHEMATIC1/Trans

21. Simulate.
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You will get this error:

.subckt X FIR CLE input_0 input_1 input_2 input_3 input_4 input_5 input 6 input_7 input_8 input_9 input_10 input_11 input_12 input_13

ERROR(ORPSIM—IEEEE): Line too long. Limit is 132 characters. I
F OPTIONEL: DPWH-SC_DPWH DGHD=SG_DGHD

+ PARBMZ:

.model FIR_TIMING ugate |

+ tplhmn=6ns tplhty=9ns tplhmz=15ns

+ tphlmn=6ns tphlty=10ns tphlmz=15ns

* )
U1 LOGICEXP({ 17, 16 ) DPWR DGHD
+ CLK input_0 input_1 input_2 input_3 input_4 input_5 input_6 input_7 input_8 input_% input_10 input_11 input_12 input_13 input_14 in

S
ERROR[ORPSIM-16366): Line too long. Limit is 132 characters.

Index has 1 entries from 1 file(s).

To solve it, RMB on the FIR component and click on Edit PSpice Model.

22. Make next modifications and do not forget to write down + at the beginning of the new
line:

ubckt ¥ FTE CLK dnput 0 dnput 1 dnput 2 dnput 3 dnput 4 dnput 5 dnput 6 dnput 7 dnput B input 9 input 10
finput_11 input_12 input_13 input_ 14 input_15 output_0 output_1 output_2 output_ 3 output_4 output 5 output_6
froutput_7 output_8 output_ 9% output_10 output_ 11l cutput_1l12 output_13 output_ 14 output 15
mU- o_DoND
+ PARAMS:

.model FIR_TIMING ugate (

+ tplhmn=6éns tplhty=9%ns tplhmx=15ns
+ tphlmn=6éns tphlty=10ns tphlmx=15ns
)

Ul LOGICEXP( 17, 16 ) DEWR DGND

CLE dnppnt 0 dnpnt 1 dnmpt 2 dnmmt 3 dnnt A dnmnt S dnmat /o dnnat 7 o dnnnit 8 dnnat 8 dnnat 10 dnopnt 17

input_12 input 13 input_14 input 15 output 0 output_l output 2 ocutput_3 output_4 output_ 5 output_6 output 7
output 8 output 9 output 10 output 11 output 12 cutput 13 cutput 14 cutput 15

+ FIR TIMING IO STD

4 C MODEL: FIR.dll SysCFIR |

+ PARAMS:

.ends

23. Close and click OK to save.
24. Simulate again and analyze the results (plot each input and each output).

NOTE: Notice that the input signal is coming from text format placed on the
Schematic.

3.3 Noise Filter using a MATLAB Block

This module explains a simple example of Analog Behavioural Model imported into PSpice
as a DMI Model. This module takes the example of a MATLAB averaging filter to
demonstrate this.

The details of generating the code may be found at
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http://www.mathworks.com/help/coder/examples/averaging-
filter.ntml?prodcode=ME&language=en

This Lab demonstrates:

- An example of MATLAB generated code imported to PSpice as a DMI model.
- Generation of a template code for an Analog behavioural model and its use in a
PSpice simulation.

Steps:
1. Launch Model Editor

2. Select Menu Item Model > DMI Template Code Generator
3. Enter the data as follows:

[m| DMI Template Code Generator <l
Use this dialog-box to auto-generate DMI template code for the following PSpice-DMI models: Analog, Digital, and
SystemC. The dialog-box also imports the Verilog-A Compact Device models using ADMS
Recommended steps:

1. Testthe model code stand-alone by building an exe.
2. Create the PSpice-DMI adapter code, and edit itin Visual Studio to insert model code.
3. Use the generated PSpice library (lib file) to create a schematic symbol The generated symbol can be placed
in the schematic for PSpice simulation.
. Part Details
Part Name NoiseFilter
Part Type Analog
: Terminals
Model Type Function-Dependent Voltage Source
Terminal Entry
: Parameters
Global Parameters
Device Parameters
Model Parameters
: Output —
DLL File Name NoiseFilter.dll
Log File Name NoiseFilter log
DLL Location D\PSpice\Application Notes'\Floy | Browse...
OK Cancel Help
Specify device parameters; and global parameters required by the model logic

Click on Browse to save the code in
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<directory>\Circuits\MATLAB_Block_Simulation\To_be_combpleted\DMI_Code
Do NOT click on OK.

4. Click on Terminal Entry — for the selected predefined model type, the number of
terminals is fixed at 4.

Terminal Entry

Number of terminals

Terminal Name Terminal Description

Input1 MNoise Input 1

Input2 Noise Input2

Outputt iouputi

Output2 oupwt2
OK Cancel Apply

5. Click OK and generate the code.
6. Verify that the code and the lib folder are created correctly:

<directory>\Circuits\MATLAB_Block_Simulation\To_be_completed\DMI_Code\NoiseF
ilter\code

NOTE: the DLL will not be created until you compile the code in Visual Studio.

NoiseFilter.log
T3 NoiseFilter.vexproj
[ NoiseFilter_user.cpp
| pspEngFunc.cpp
[ pspEngFunc.h
5 PSpiceBase.h
[{] PSpiceCMIApiDefs.h
] PSpiceCommonAPIDefs.h
[ PSpiceDigApiDefs.h
0O pspNoiseFilter.cpp
[ pspNoiseFilter.h
[J StdAfx.cpp
[ StdAfxh

<directory>\Circuits\MATLAB_Block_Simulation\To_be_completed\DMI_Code\NoiseF
ilter\lib
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i) input,json
2 NoiseFilter.lib

7. Launch Visual Studio Community 2013 and open the file NoiseFilter.vcxproj

FILE | EDIT VIEW DEBUG TEAM TOOLS TEST ANALYZE WINDOW  HELP
New » Fh he v M
Open * | 8 Project/Solution.. Ctrl+Shift+O
Close @ Web Site... Shift+Alt+O
)se Solution Open from Source Control
Save Selected Ite Ctrl+S 1% Team Project..
Save Select / 21 File. Ctrl+0
¥ Save All Ctrl+Shift+S Gorvest)
Export Template..
Source Control »
Page Setup...

The project is located in

<directory>\Circuits\MATLAB_Block_Simulation\To_be_completed\DMI_Code\NoiseF
ilter\code

sotution explorer = > |
@ e--a@m F -

Search Solutior

taJ Solution ‘NoiseFilter' (1 project)
4 %] NoiseFilter

+= External Dependencies
*+ NoiseFilter_user.cpp

*+ pspEngFunc.cpp

B pspEngFunch

B PSpiceBase.h

B PSpiceCMIApiDefs.h

B PSpiceCommonAPIDefs.h
B PSpiceDigApiDefs.h

*++ pspNoiseFilter.cpp

B pspNoiseFilter.h

*++ StdAfx.cpp

P B StdAfxh

4
P
4
b
b
b
b
b
P
b

8. Change the configuration on the top as follows:

~ |Release ~ x64 || B
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9. Select Menu Item Build/Build Solution and verify that the Build completes
successfully.

OlTi IV Solution Explorer

Show output from: | Build -

1>------ Build started: Project: NoiseFilter, Configuration: Release x64 ---
1> MNoiseFilter_user.cpp

1> pspEngFunc.cpp

1> pspNoiseFilter.cpp

1> StdAfx.cpp

1> Creating library D:\PSpice\Application Notes\FlowCAD AN Device_Modeli
1> Generating code

1> Finished generating code

1> NoiseFilter.vcxproj -»> D:\PSpice\Application Notes\FlowCAD_AN_Device_ Mod
---------- Build: 1 succeeded, @ failed, @ up-to-date, @ skipped ==========

10. The PSpice-DMI template code is ready. Now, the model behaviour for the exported
averaging filter (using C-Coder in MATLAB) needs to be inserted in the code.

11. Open NoiseFilter_user.cpp for editing:

Under the line:
#include "pspNoiseFilter.h"

Add the text:

extern "C" {
#include "../../averaging_filter/averaging_filter.h"

}

This includes the MATLAB generated header file so that its Averaging filter function
can be accessed.

12. Edit the load function as follows:
Under the line:
double gain = 0.9;

Add the text:

// User Code
if (pMode != MDTRAN) {
for (int 1 = @; i < 16 + MSTVCT; i++) {
sv.x[1] = xVal;
h
|
sv.y[@] = yVal = averaging filter(xVal, sv.x);
!/

This code will update the state vector with the latest input value, and call the MATLAB
averaging_filter function to compute the gain.
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13. Finally, add the MATLAB averaging_filter file to the project. In the solution Explorer,
RMB on NoiseFilter and select Menu Item Add — Existing Item

b 5 Externg & Build
b ++ Noisefi Rebuild
P *+ pspEng Clean
P B pspEng e »
b B PSpicel A .
P B PSpicel e
b PSpicel Project Only L4
b B PSpicel Scope to This
P % pspNoj B! New Solution Explorer View
P B pspNoi
++ StdAfx. Profile Guided Optimization 4
b B StdAfx. Build Dependencies 4
Add * | 'O Newltem.. Ctrl+Shift+A
B* Class Wizard.. Ctrl+Shift+X | %3  Existing Item.. Shift+Alt+A
-] Manage NuGet Packages... T8 New Filter
G Set as StartUp Project References...
Nakhiin L

14. Browse to ../../averaging_filter and select the averaging_filter.c

o Add Existing Item - NoiseFilter il
OO ll « Complete » DMI_Code » averaging_filter » v|+¢|| averaging._filter durchsu... 2
Organisieren ~ Neuer Ordner = o 1 @
4. Musik = Name Anderungsdatum Typ GroBe =
#& OneDrive )
I interface 20.06.2016 09:49 Dateiordner
<p Zuletzt besucht
B averaging_filter.c 21.03.2016 12:59 C Source 2K
e [ averaging_filterh 21.03.2016 12:59 C/C++ Header 1K=
~ Bibliotheken
' . S averaging_filter.lib 21.03.2016 12:59 LIB-Datei 8K
~. Bilder : ; e = B
jl [ averaging_filter_initialize.c 21.03.2016 12:59 C Source 1K
‘.. Dokumente = as -
_ [k averaging_filter_initialize.h 21.03.2016 12:59 C/C++ Header 1K
4. Musik i . :
i averaging_filter_ref.rsp 21.03.2016 12:59 RSP-Datei Ok
B videos S = :
<./ averaging_filter_rtw.bat 21.03.2016 12:59 Windows-Batchda... 1k
Bﬂ averaging_filter_rtw.mk 21.03.2016 12:59 Makefile 12 k
& Computer o ) -
. [@ averaging_filter_terminate.c 21.03.2016 12:59 C Source 1k
&> Windows7_0S (C) - T :
[\ averaging_filter_terminate.n 21.03.2016 12:59 C/C++ Header 1k
» Data2 (D) o _— z z X
[l averaaina filter tvoes.h 21.03.2016 12:59 C/C++ Header 1k
& support (\dc01) ( ~ « 1 3
Dateiname: averaging_filter.c - [AII Files (**) v}
| Add | [ Abbrechen |

15. Build Solution from the Menu Item Build/Build Solution and verify it works.

16. Open the location
<directory>Circuits\MATLAB_Block_Simulation\To_be_completed\DMI_Code\NoiseFi
lter\code\x64\Release and verify that the DLL and the PDB have been generated:
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NoisefFilter.tlog

% averaging_filter.obj

! NoiseFilter.Build.CppClean.log

NoiseFilter.dll
NoiseFilter.exp

S| NoisefFilter.lib
NoiseFilter.log

&) NoiseFilter.pdb

*z NoiseFilter_user.obj

45 pspEngFunc.obj

‘f,‘! pspNoiseFilter.obj

4% StdAfx.obj

&) vcl120.pdb

17. Launch Model Editor from PSpice Accessories.
18. Click Done

19. Click File->Open and select the library generated with DMI Template Code
Generator. This is located in
<directory>/circuits/ MATLAB_Block_Simulation/To_be_completed/DMI_Code/NoiseFi

Iter/lib

« Complete » DMI_Code » NoiseFilter » lib v|+,|| lib

;n~- Neuer Ordner

= Name Ander
Irive = o .

=| NoiseFilter.lib
zt besucht

m

heken

20. Select the component you have just loaded and click on File->Export to Part Library:
Create Parts for Library X4

Enter Input Model Librany:

lationyComplete\DMI_Code\NoiseFilter\lib\MNoiseFilter lib Browse...

Enter Output Part Library:

stionyComplete\DMI_Code\NoiseFilteflib\NoiseFilter.olb | Browse.. ‘
Ok Cancel ] [ Help

21. Click OK. A window indicating that everything worked properly should pop up:
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D:\temp\Circuits\MATLAB_Block_Simulation\To_be_completed\DMI_Code\NoiseFilter\lib\MoiseFilter.err 53]

STATUS: PSpice Schematics to Capture translator (17.2.0.d0071) -
STATUS:

STATUS: Translator started at Mondasy, Juby 17, 2016 18:18:05

STATUS: C\Cadenceh3FE_17 2toolsihiniachZoap | "DMempyCircuits\WMATLAB_Block_SimulatiorhTo_be_completec
INFOIORSCH-1029): Using existing library 'C\Cadence\SPE_17.2\tools\CaptureiLibranAPSpiceymodeled etc’.
INFO[ORSCH-1031): Created new library 'DitempCircuits\MATLAE_Block_Simulation\ To_be_completed\DhI_Codel
STATUS: Translator stopped at Monday, July 11, 2016 18:18:05

STATUS: 0 Error messages, 0Warning messages

22. Copy NoisefFilter.lib and NoiseFilter.olb from

<directory>/circuits/MATLAB_Block_Simulation/To_be_completed/DMI_Code/NoiseFi
lter/lib

and paste them in

<directory>/Circuits/MATLAB_Block_Simulation/To_be_completed/Circuit/Library/Cap
ture

23. Launch OrCAD Capture and open the MatlabBlock design located in
<directory>/Circuits/MATLAB_Block_Simulation/To_be_completed/Circuit

24. Click on Add Library, select the NoiseFilter.olb symbol and place it in the schematic:

<directory>/circuits/MATLAB_BIlock_Simulation/To_be_completed/Circuit/Library/Cap
ture

25. Create a new Simulation Profile and name it Trans.
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New Simulation

MName:

Trans

Inherit From:

| R

Cancel

none

7] (e

Foot Schematic:

SCHEMATIC1

26. Complete the values like in the image:

) simulation Settings - Trans

Gi

'| Analysis | Configuration Files [ Options ] Data Collection | Probe Window |

Analysis type:
[Time Domain (Transien) ~ |

Options:

[1Monte Carlo/Worst Case
[1Parametric Sweep

[ Temperature (Sweep)
[1Save Bias Point

[Load Bias Point

[Save Check Points
[JRestart Simulation

|6 seconds (TSTOP)
|IJ seconds
Transient options

Maximum step size: |Im seconds

[ Skip the initial transient bias point calculation (SKIPBP)

Run to time:

Start saving data after.

[ Runinresume mode Output File Options...

[ ok ][ Aobrechen | [ Ubemenmen Hife |

27. Without closing the Settings select Configurations Files and add to Design the

NoiseFilter.lib:

@ Simulation Settings - Trans

:_'GeneraI]Anatysis Configuration Files . Options I Data Collection ]Probe Window'_

Details

Eil
F

Category:

-

(=]

Stimulus [
Include Configured Files

Browse...
X 3 =

[v Update Index

@nomlib

< i

Library Path

[ \iibrary\capture\noisefilter.lib

Add as Global
Add to Design
Add to Profile
Edit
Change

"C\Cadence\SPB_17.2\tools\PSpice\Library"

— )

OK || Abbrechen |  Ubem Hilfe
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28. Click OK.

29. Before simulating, place the created NoiseFilter.dll and its .pdb in the Simulation
Profile Folder.
DLL Location:

<directory>/Circuits/MATLAB_Block_Simulation/To_be_completed/DMI_Code/NoiseF
ilter/code/x64/Release

Simulation Profile Location:

<directory>/Circuits/MATLAB_Block_Simulation/To_be_completed/Circuit/MatlabBloc
k-PSpiceFiles’SCHEMATIC1/Trans

30. Simulate and verify it works:
31. Analyze the results. Click on PSpice - Markers - Voltage Level.

m,&ccessories Options Window Help

= New Simulation Profile :j E:J }Q -r{': @
Edit Simulation Profile

© Run F11
View Simulation Results F12 @

View Output File

Create Netlist

View Netlist

Advanced Analysis 4

Markers A3 Voltage Level N
Bias Points » 4 Voltage Differential

#8 Current Into Pin

anon e

32. Place the markers like in the image:

1U‘ 3 /

Et —1 INPUT1 OUTPUT1 [T

— INPUT2 OUTPUT2
EVALUE NOISEFILTER
V(IN+0.3*RND

-

(=]
(=]
Ay

=

33. Open Probe Window:
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3.4 Capacitor behaviour analysis defined using VerilogA-
ADMS

This module explains the import of a VerilogA file and its translation to a DMI model.
VerilogA import in PSpice is supported using ADMS parser — this is primarily useful for
importing VerilogA compact models.

This Lab will demonstrate:
- An example of a capacitor model written in VerilogA, using 2 parameters to specify
the capacitance value.
- Import of a VerilogA file using Model Editor and translation into PSpice-DMI model.
- Sample simulation and comparison of the results with a regular capacitor simulation.

Steps:

1. Launch Model Editor from PSpice Accessories:

@ 7spico Moot Eavor fslarsl
Filg Edit View Mod@ Plot Tools Winoow H cadence”
LB R RUD AGAS W EV JOEHEB

Pros)
wwwww

2. Select Model > DMI Template Code Generator.
3. Enter Part Name as cap

NOTE: Part Name should match the module name specified in the VerilogA file.
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4. Inthe DMI Template code Generator Ul, select Part Type as VerilogA-ADMS

5. In Verilog-A File field, enter the path to the cap.va file located in the

VerilogA_component folder:

<directory>/Circuits/VerilogA_Capacitor/To_be_completed/VerilogA_Component

NOTE: The XML Folder is automatically selected by the tool. You do not have to

browse anything.

6. Inthe Output, select only the DLL Location to:

<directory>/Circuits/VerilogA_Capacitor/To_be_completed/DMI_Code

8| DMI Template Code Generator

Use this dialog-box to auto-generate DMI template code for the following PSpice-DMI models: Analog, Digital, and
SystemC. The dialog-box also imports the Verilog-A Compact Device models using ADMS

Recommended steps:

1. Testthe model code stand-alone by building an exe

2 Create the PSpice-DMI adapter code, and edit itin Visual Studio to insert model code
3. Use the generated PSpice library (lib file) to create a schematic symbol.The generated symbol can be placed

in the schematic for PSpice simulation

Part Details
Part Name
Part Type
Input
Verilog-AFile
XML Folder
Qutput

DLL File Name
Log File Name

DLL Location

cap

VerilogA-ADMS

DAPSpice\Application Notes'Flo

CiCadence\SPB_17 2\tools\psp

cap.dll
cap.log

D\PSpice\Application Notes'\Floy

Browse..

Browse..

Browse

OK Cancel Help

The cap.va is a VerilogA model for a capacitor which uses 2 parameters to define the

capacitor values: C1 and C2.

“include "discipline.h"

module cap(p,n);

inout p,n;

electrical p,n;

parameter real c1=0 from [0:inf);
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7. Click OK. The DMI model is auto-generated from the VerilogA file and a log file is

parameter real c2=0 from [0:inf);
analog

I(p,n) <+ ddt((c1+2*c2)*V(p,n));
endmodule

generated listing the translation steps.

1| capllog - Editor o @8
Datei Bearbeiten Format Ansicht ?

Reading json

Json read..Logging Model Creation..

reading Model Name and Type.

reading global and instance params for digital and analog..

Copying common files .

Replacing the Model Name in C:\Cadence\SPB_17. 2\tools\pspice\tclscripts\pspModelCreate\Veril

Uer1102 -A Path : D:/PSpice/Application Notes/FlowCAD_AN_Device_Modeling_Interface/Circ
Name of verilog-A file : cap.va

Verilog-A Location : D:/PSpice/Application Notes/F1owCAD_AN_Device_Modeling_ Interface/C1rﬂ
XMLs Location : C:/Cadence/SPB_17.2/tools/pspice/api/adms/xmls/

Generating Files

:\Cadence\SPB_17.2/tools/pspice/api/adms/bin/admsxml.exe -ID:/PSpice/Application Notes/Flow
:\Cadence\SPB_17.2/tools/pspice/api/adms/bin/admsxml.exe -ID:/PSpice/Application Notes/Flow
:\Cadence\SPB_17.2/tools/pspice/api/adms/bin/admsXml.exe -ID:/PSpice/Application Notes/Flow
:\Cadence\SPB_17.2/tools/pspice/api/adms/bin/admsxml.exe -ID:/PSpice/Application Notes/Flow
:\Cadence\SPB_17.2/tools/pspice/api/adms/bin/admsXml.exe -ID:/PSpice/Application Notes/Flow
:\Cadence\SPB_17.2/tools /pspice/api/adms/bin/admsxml.exe -ID:/PSpice/Application Notes/Flow
:\Cadence\SPB_17.2/tools/pspice/api/adms/bin/admsxml.exe -ID:/PSpice/Application Notes/Flow
:\Cadence\SPB_17.2/tools/pspice/api/adms/bin/admsXml.exe -ID:/PSpice/Application Notes/Flow
:\Cadence\SPB_17.2/tools/pspice/api/adms/bin/admsxml.exe -ID:/PSpice/Application Notes/Flow
:\Cadence\SPB_17.2/tools/pspice/api/adms/bin/admsXml.exe -ID:/PSpice/Application Notes/Flow
:\Cadence\SPB_17.2/tools/pspice/api/adms/bin/admsxml.exe -ID:/PSpice/Application Notes/Flow
:\Cadence\SPB_17.2/tools/pspice/api/adms /bin/admsXml.exe -ID:/PSpice/Application Notes/Flow
:\Cadence\SPB_17.2/tools/pspice/api/adms/bin/admsxm].exe -ID:/PSpice/Application Notes/Flow
:\Cadence\SPB_17.2/tools/pspice/api/adms/bin/admsXml.exe -ID:/PSpice/Application Notes/Flow
:\Cadence\SPB_17.2/tools/pspice/api/adms/bin/admsxm].exe -ID:/PSpice/Application Notes/Flow
:\Cadence\SPB_17.2/tools/pspice/api/adms/bin/admsXm].exe -ID:/PSpice/Application Notes/Flowt
Creating Visual Studio Project

Populating vcproj with the source and header files

read input file C:\Cadence\SPB_17.2\tools\pspice\tclscripts\pspModelCreate‘\VverilogATemplate\
opened output file D:/PSpice/Application Notes/FlowCAD_AN_Device_Modeling_Interface/Circuits,

‘slalalslalalslalatalalatalslnlsl

D:\PSpice\Application Notes‘FlowCAD_AN_Device_Modeling_Interface\Circuits\VerilogA_Capacitor’
cl /D "_WINDLL" /D "_MBCS" /D "_CRT_SECURE_NO_WARNINGS" /02 /GL /FD /EHMsc /MT /W3 /nt_

‘ 1 b

8. The generated code is automatically compiled using nmake. If there are no build

errors, the dIl and the lib files are generated, and can be directly used in a PSpice

Simulation.

<directory>/Circuits/VerilogA_Capacitor/To_be_completed/DMI_Code/cap/lib

| code
I lib

DIl file created in the folder code:
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.adms.implicitxml
.capva.adms
.interfacexmil
0 analogfunction.cpp
[k analogfunction.h

[J cap.cpp

cap.dll

cap.dil.manifest
cap.exp
[ cap.h
5| caplib
cap.log
"j cap.vcxproj
0 capacld.cpp
[ capdefs.h
5] capguesstopology.cpp
0 capload.cpp

[3 caonoise.con

e Lib file created in the folder lib:
Lsubckt cap_sub p n PRARAMS: cl=0 c2=0
Y1 p n CHI cap.dll cap mod

model cap mod CMTI cap cl={cl} cZ={cl}
Lends

9. Copy the cap.lib and paste it in
<directory>\circuits\VerilogA_Capacitor\To_be_completed\Circuit\Library\Capture
in order to generate the symbol (olb) to be used in Capture.

10. Copy the DLL and paste it in
<directory>\circuits\VerilogA_Capacitor\To_be_completed\Circuit\Library\DLL

11. Open Model Editor from PSpice Accessories
12. Click on File = Open and look for cap.lib in

<directory>\circuits\VerilogA_Capacitor\To_be_completed\Circuit\Library\Capture
13. Click on File > Export to part library
Create Parts for Library &3

Enter Input Model Library:
verilogA_Capacitor\Complete\DMI_Codelcapilib\cap.lib Browse...

Enter Output Part Librany:
‘erilogA_Capacito\Complete\DMI_Code\cap\lib\cap.olb Browse...
OK | | Cancel | [ Help

14. Now open in OrCAD Capture the example design where you are going to evaluate a
capacitor from the default Cadence library and the capacitor you have just defined.
Click on File->Open->Project and select the project located in

<directory>\Circuits\VerilogA_Capacitor\To_be_completed\Circuit\Example.opj
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m Design Edit

MNew
Open
Close

' = Save

| Check and Save
Save As...
Save Project As...
Archive Project...
Import
Export
Print Preview...
Print...
Print Setup...
Print Area

View Tools

Ctrl+F4
Ctrl+S

Ctrl+P

1 D:\PSpice\..\Example.opj

Place SI Analysis

PSpice

» r -
Demo Designs
Project...
Design...
Library...

VHDL File...
Verilog File
Text File...
PSpice Library

16. Make double click on Page1 from the schematic Cap:

TF=1u
PER = 20u

S | SN S—— g "y

17. Click on Place Part and select C from the library analog.olb:

Place Part

Part:

c
Part List:

T x

Libraries:

ADV_LIN
ANA_SWIT
AMNALOG
ANALOG_P
ANL_MISC
ANLG_DEV

C?
HE
1n

Packaging
Parts per Pkg: 1

-

Type: Homogeneous

@ Mormal
‘T] Search for Part

Convert
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18. Place it in the schematic and change the value to 5n

Vi=0 V1

v2=5 @ R1
TD=1n 200
TR=1u

TF = 1u

PW = 10u

PER = 20u

T2

19. Create a new Simulation Profile and call it Trans:

b

2 Q& B4 A4 4G

New Simulation Profile k

AGET [l W

25. Complete the Simulation profile with these values:

g Simulation Settings - Trans

_. GeneraI: Analysis :Conﬁgmaljon Files [ Options | Data Collection | Probe Window:

Analysis type:
|Time Domain (Transienf) ﬂ

Options:

™ General Settings
_IMonte Carlo/Worst Case
_1Paramefric Sweep
C1Temperature (Sweep)
_1Save Bias Point

[lLoad Bias Point

"1Save Check Points
_IRestart Simulation

Run to time: 60u seconds (TSTOF)

0 seconds
Transient options
Maximum step size: seconds

[~ Skip the initial transient bias point calculation (SKIPBP)

Output File Options...

Start saving data after:

[~ Runin resume mode

oKk | [ Abbrechen Hilfe

26. Click OK.
27. Run the simulation clicking

on Play.

28.In OrCAD Capture click on PSpice - Markers - Voltage Level and place the

markers as in the image:
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29. Analyse the results:

Application Note
oy \
TE}; n @ 3 20
TR=
TF=1y
PW = 10
FER = 20u .
o
i !] ; 'II
| 1 | fl
[ ]
| | |
I | |
J % | :
|
=
EnEnnEED P EEEESSes

22. Come back to OrCAD Capture, select the DMICap Schematic and with RMB make it
Root. Now you are going to simulate your Verilog-A Cap.

SR=l DMICap
@ PAGE1| New Page
#-00 Design Ca¢  Make Root
© Library Rename l}
Outputs :
Properties

PSpice Resources
€3 Include Files
€3 Model Librari¢  Find
2 Simulation Pr¢ » Cut
O Stimulus Files | @ Copy

Edit Object Properties

Reports
Lock

Delete

NOTE: If you have not saved, it will ask you automatically. Click on Save.

23. Click on Add Library and select the .OLB you have created

<directory>/Circuits/VerilogA_Capacitor/To_be_completed/Circuit/Library/Capture
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panalog  Bd

dbraries:

T =

Packaging
Parts per Pkg: 1

C?

Part: -

and place the capacitor changing the values of C1 and C2 to 1n. You will find these
properties making double click on the DMICAP.

R
200

A
DMICap : PAGE1 : 1
Bias\Value Power oWy
c1 1n
c2 1n
Color Default
Designator
Graphic CAP_SUB.Normal
[Desiqnator ]

Implementation CaP_SUB
Implementation Path ]
Implementation Type PSpice Model

Location X-Coordinate 410
Location Y-Coordinate 140
Hame INSFO7
Part Reference Iy
PCB Footprint
Power Ping Visible =
Primitive DEFAULT
PSpiceTemplate XMY@REFDES %P %N @mMo
Reference Iy
Source Library CATEMPORALNTESTC []
Source Package CAP _SUB
Source Part CAP_SUE Normal
Value CaP_SUB

24. Create a new Simulation profile called Trans, with the same values than before and click

Configuration Files and Libraries:
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@; Simulation Settings - Trans N e
_. General | Analysis Configuration Files .Opliuns Data Collection | Probe Window
i Details
Category: Filename:

o | =
Include Configured Files llll i!

[¥ Update Index _r}g::ahrl\;r\capture\cap lib s
. Add to Design
Add to Profile
Edit
Change

« 1 3
Library Path
i"C:\Cadence\SPB_‘l?.2\10ols\F‘Spice\Library" Browse...
oK | Abbrechen | | Ubemehme Hife |

25. Add to Design the .lib generated you located in
<directory>/Circuits/VerilogA_Capacitor/To_be_completed/Circuit/Library/Capture

26. Before simulating, you have to place the .DLL in the Simulation Profile Folder you have
just created. Place it in:

<directory>\VerilogA_Capacitor\To_be_completed\Circuit\Example-
PSpiceFiles\DMICap\Trans

| cap.dll
& cap.pdb
2| Trans.10P
Trans.cir
Trans.dat
= Trans.mif
Trans.mrk
2| Trans.out
Trans.out.1

=| Trans.prb

27. Simulate and analyse the results placing the markers as done before:
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3.5 Debugging

This section explains how the behaviour of DMI Models can be debugged on the circuit
where it has been designed. There are two options to debug DMI models. To understand
both of them, you will use the project that is located in
<directory>\Circuits\Debugging\Circuit\MatlabBlock.opj

Option 1: Setup path to psp_cmd.exe in Visual Studio

1. Open Visual Studio Community 2013
2. Click File->Open->Project/Solution and search for:

<directory>\Circuits\Debugging\DMI_Code\NoiseFilter\code\noiseFilter.vcxproj
3. Ensure DEBUG profile is selected on the top:

ANALYZE WINDOW  HELP
~ |Debug ~ |x64 || A" <

4. Select the project with RMB and select properties:
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faJ Solution 'NoiseFilter' (1 project)
Y o D&T 5, 4 Build —
b ++ av Rebuild
P+ Ne Clean
P % pg View 4
i E E; Analyze »
b ps Project Only »
b PS Scope to This
b & B New Solution Explorer View
b *+ ps
> B ps Profile Guided Optimization 4
++ St Build Dependencies 4
b B St Add "
g Class Wizard... Ctrl+Shift+X
] Manage NuGet Packages...
£} SetasStartUp Project
Debug »
Source Control »
b Cut Ctrl+X
Paste Ctrl+V
X Remove Del -
Y - | B L Rename
Descripf Unload Project
Rescan Solution
c Open Folder in File Explorer
#  Properties N Alt+Enter
5. A window pops up. Click on Debugging and setup three property values:
Command Enter absolute path to psp_cmd.exe
Command Arguments Enter absolute path to cir file which contains the C Model instance
Working Directory Enter the absolute path to the directory which contains the cir file

For this example:

Command:
%CDSROOT%\tools\bin\psp_cmd.exe

Command Arguments:
<directory>\Circuits\Debugging\Circuit\MatlabBlock-
PSpiceFiles\SCHEMATIC1\Trans\Trans.cir

Working Directory:
<directory>\Circuits\Debugging\Circuit\MatlabBlock-PSpiceFiles\SCHEMATIC1\Trans
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OISEFIITEr FIOPENTY Fages
Configuration: .Active(Dehug]

B Common Properties
4 Configuration Properties |
General -
Debugging
VC++ Directories
b C/Cs+
b Linker
& Manifest Tool
B XML Document Generator
i Browse Information
b Build Events
¥ Custom Build Step
B Code Analysis

| Debugger to launch:

Local Windows Debugger

Command

Command Arguments

‘Working Directory

Astach

Debugger Type

Environment

Merge Environment

S0L Debugging

Amp Default Accelerator
Command

The debug command 1o execute.

= | Platform: |Active(x64)

B s

> | Configuration Manager—

C:\Cadence\SPB_17.2\tools\bin\psp_cmd.exe =
D:\PSpice’\Application Notes\FlowCAD_AMN_Device_ Modeling_Interface’\Circuits\Debugging\Circ

D:\PSpice\Application Notes\FlowCAD_AN_Device Modeling_Interface\Circuits

Ne
Auto

Yes
No

WARP software accelerator

6. Verify that you have the same values in the next options:

e (Click on Optimization inside of C/C++

ire

syss Property Pages

Configuration: [AII Configurations

4 Configuration
General

4 C/C++
General

~

> Common Properties -

Debugging
VC++ Directories

Optimization
Preprocessor

Code Generation
Language
Precompiled Headers
Output Files

Properties

m

4] 11

1% ][
¥ | Platform: |Active(x64) v] [ Configuration Manager... l
Optimization Disabled (/Od)
Inline Function Expansion Default
Enable Intrinsic Functions
Favor Size Or Speed MNeither

Omit Frame Pointers
Enable Fiber-5afe Optimizz No
Whole Program Optimizati

' Optimization

Select option for code optimization; choose Custom to use specific optimiza...

OK

H Cancel H Apply
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e (Click on Debugging inside of Linker:
syss Property Pages ? || &3 |

Configuration: |All Configurations * | Platform: |Active(x64) VI [ Configuration Manager... ]
All Options A Generate Debug Info Yes (/DEBUG)
Command Line Generate Program Databas $(OutDin$(TargetName).pdb

4 Linker Strip Private Symbols
General Generate Map File No
Input Map File Name
Manifest File - Map Exports No
Debugging Debuggable Assembly
System =
Optimization i
Embedded IDL L
Windows Metadata
ilc:vgnied Generate Debug Info
i i |0n.s. : ~ | | The /DEBUG option creates debugging information for the .exe file or DLL
€ | 1 | ¥
0K ll Cancel ll Apply

7. Click Apply and OK.

8. Open file NoiseFilter_user.cpp and add breakpoints clicking on the desired line:

Output Solution Explorer NoiseFilter_user.cpp + X

| & NoiseFilter
//double xVal = fp_getV(OutPortl,0OutPort2);
double xVal = fp_getV( Inputl , Input2 );
double delta = fp_getDelta();
double yVal = 0.0;
double gain = 0.9;

// User Code
[} if (pMode != MDTRAN) {
@ for (int i = @; i < 16 + MSTVCT; i++) {
sv.x[1] = xVal;

}
IQI sv.y[@] = yVal = averaging_filter(xVal, sv.

/!

fp_applyValueltem(ribr,yVal );
fp_applyValueItem(Outputl_cibr,1);
fp_applyValueltem (Output2_cibr, -1);
fp_applyValueltem (cibr_Outputl, 1 );
fp_applyValueIltem (cibr_Output2, -1 );

return returnVal:
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9. Run the simulation in debug mode
DEBUG | TEAM TOOLS TEST ANALYZE WIND!
Windows >t
Graphics >
P Start Debugging F5 Nl
P Start Without Debugging Ctrl+F5 1
@ Attach to Process...
Other Debug Targets 4
Exceptions... Ctrl+Alt+E
Performance and Diagnostics Alt+F2
G. StepInto F11
E'. Step Over F10
Toggle Breakpoint F9
New Breakpoint 4
& Delete All Breakpoints Ctrl+Shift+F9
Disable All Breakpoints
Clear All DataTips
Export DataTips ...
Import DataTips ...
Options and Settings...
#  NoiseFilter Properties...
10. Choose Yes on the following message:
No Debugging Information (7 [ =]
N Debugging information for 'pspice.exe’ cannot be found or does not match. Cannot find or

open the PDB file.

Do you want to continue debugging?

["] Don't show this dialog again

Yes ; No

11. Observe that simulation stops at breakpoint:
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double yVal = 0.9;
double gain = 0.0;
// User Code
® if (pMode != MDTRAN) {
for (int 1 = 0; 1 < 16 + MSTVCT; i++) {
© sv.x[i] = xVal;
}
_ }
[ ) sv.y[@] = yVal = averaging_filter(xVal, sv.x);
//
12. Click on Continue to jump from one breakpoint to another one.
DEBUG TEAM TOOLS  TES
- | P Continue v ¢ ~
' Lifecycle Events ~ Thread:
-[> pspN
13. Use Visual Studio Watch function to see any variable value
Code %1 Insert Snippet.. Ctrl+K, Ctrl+X
(pMode 1= MDTR 4 gyrround With.. Ctrl+K, Ctrl+S
for (int i = |
sv.x[i] =| & Peek Definition Alt+F12
¥ " Go To Definition F12
= -
: F
FIOT = gVal = £ Go To Declaration Ctri+F12
Find All References Shift+F12
= View Call Hierarchy Ctri+K, Ctrl+T
sppiyValueTten Toggle Header / Code File Ctrl+K, Ctrl+O
applyValueItem Breakpoint »
annlwvValueTtem
&> Add Watch [}
- é  Add Parallel Watch I
Vs 6> QuickWatch... Shift+F9
N M Pin To Source del

NOTE: If it is said that the project is out of date or you make many changes in the
code, build the project again, copy .dll and .pdb and past them in the Simulation
Profile Trans, so that you can debug properly.
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Name Value Type
@ MDTRAN MDTRAN (3) modeFla
@ gain 0.00000000000000000 double
@ pMode i int
P @ this 0x0000000002860e80 {Input1=0x0000000002860ea0 "N01546" pspNoise

Option 2: Attach Visual Studio to PSpice
1. Open Visual Studio and load the previous project.
<directory>\Circuits\Debugging\DMI_Code\NoiseFilter\code\NoiseFilter.vcxproj
2. Open the project in OrCAD Capture
<directory>\Circuits\Debugging\Circuit\MatlabBlock.opj

3. Open NoiseFilter_user.cpp and place your breakpoints in the code

// User Code

® if (pMode != MDTRAN) {
o for (int i = @; i < 16 + MSTVCT; i++) {
sv.x[i] = xVal;
}
¥
® sv.y[@] = yVal = averaging_filter(xVal, sv.x);

/7

4. In Visual Studio, click on Tools—>Attached to process:
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Afttach to Process @
Transport: Default v
Qualifier: FC-RGANDIA x Find...

Transport Information

The default transport lets you select processes on this computer or a remote computer running the Microsoft Visual Studio Remote
Debugging Monitor (MSVSMON.EXE).

Aftach to: Automatic: Native code

Available Processes

Process ID Title Type User Name Session 4
SCHTASK.EXE 9028 x86 FC-EDA\rgandia 1
simmgr.exe 10416 x64 FC-EDA\rgandia 1
SimSrvr.exe 1244 x64 FC-EDA\rgandia il
Skdaemon.exe 7148 x64 FC-EDA\rgandia sk
SpotifyWebHelper.e.. 7224 x86 FC-EDA\rgandia 1
SynTPEnh.exe 7064 x64 FC-EDA\rgandia 1
SynTPHelper.exe 10016 x64 FC-EDA\rgandia [a.. 1
SynTPLpr.exe 6644 w64 FC-EDA\rgandia 1
taskeng.exe 4472 x64 FC-EDA\rgandia 1 F
taskeng.exe 5848 %64 FC-EDAVrgandia [a.. 1 =
taskhost.exe 3716 x64 FC-EDA\rgandia 1 =

[] Show processes from all users

5. Select all the SimSrvr.exe available (clicking on Ctrl+LMB) and click on Attach.
6. Click on Run Simulation in PSpice

7. If everything works fine, PSpice keeps running and the pointer remains in VS:

INEO(ORPROBE—BEDQ): Simulation Profile: SCHEMATICI-Trans
/pspCorelLos A . )
/pspinit. tec INFO[ORPROBE-3183): Simulation running...

L=
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]
]
@

-

double yVal
double gain

I
@
@

-

// User Code
@ if (pMode != MDTRAN) {
for (int i = @; i < 16 + MSTVCT; i++) {
()] sv.x[i] = xVal;
}

¥
[ ] sv.y[@] = yVal = averaging_filter(xVal, sv.x);
//

8. Click on Continue to jump from breakpoint to breakpoint.

DEBUG TEAM TOOLS  TES
- | » Continue +  ~

3 Lifecycle Events ~ Thread: {

-] 3 pspn

9. Use Visual Studio Watch function to see any variable value

‘ial::evaluate(double pTicks, PSpiceState*

: mDigsSimTimeStep*nTicks:

= - mPre 41 Insert Snippet...

wels 11 Surround With...

ods) L

-ates[7 - m Go To Definition

, Go To Declaration

i)

itates[15 Find All References

i) View Call Hierarchy

pVectory Toggle Header / Code File
Breakpoint

i) { & Add Watch

EF[1]; | é» Add Parallel Watch

Watch 1 - M X

MName Value Type
74 mDigSim TimeSt 1.0000000000000000e-010 | double |
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3.6 Hardware in the Loop using Arduino

This module shows Hardware in the Loop using an Arduino Board where the communication
between the physical board and PSpice is done using Serial USB protocol.

This board has been chosen because it is worldwide used for multiple applications, it is
cheap and it allows to demonstrate this new PSpice feature. Of course another boards could

be used.

This example demonstrates:

e The advantages of using Virtual Prototyping in PSpice, focusing it to Hardware in the
Loop, where data flows from PSpice to the board and vice versa.

e How to define a component using DMI Template Code Generator in the context of

Hardware in the Loop.

The steps to be followed to design such example are more or less the same than for Digital
Power Supply, but some extra steps have to be considered. Let start with the next schema:

Define Arduino Board I/O

type

with DMI as analog part F——>

Define communication
between PSpice and the
board using USB serial
protocol creating VS
project

Define the code you want
to evaluate in Arduino

v

Define the code you want

generate .dll

to evaluate in PSpice and |——>

Associate macro-model to
schematic on OrCAD
Capture canvas

Run PSpice simulation and
analyze results

Steps:
1. Launch Model Editor

2. Select Menu Item Model > DMI Template Code Generator

Enter the data as follows:
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® | DMI Template Code Generator 3

Use this dialog-box to auto-generate DMI template code for the following PSpice-DMI models: Analog, Digital, and
SystemC. The dialog-box also imports the Verilog-A Compact Device models using ADMS
Recommended steps:

1. Testthe model code stand-alone by building an exe

2. Create the PSpice-DMI adapter code, and edititin Visual Studio to insert model code

3. Use the generated PSpice library (lib file) to create a schematic symbol The generated symbol can be placed
in the schematic for PSpice simulation

Part Details
Part Name ArduinoHILDemo1
Part Type Analog
Terminals
Model Type Voltage-Controlled Voltage Source
Terminal Entry
Parameters
Global Parameters
Device Parameters
Model Parameters
Output
DLL File Name ArduinoHILDemo1.dll
Log File Name ArduinoHILDemo1.log
DLL Location DAPSpice\Application Notes\Floy | Browse... |
oK Cancel Help

Specify device parameters; and global parameters required by the model log

On Terminal Entry, this is what you have to see:

Terminal Entry x
Number of terminals 4

Terminal Name Terminal Description ~
Input1 Control Input 1

Input2 Control Input 2

Qutput1 Qutput 1

Output2 Output 2

OK | Cancel ' Apply

For the DLL Location select please the directory of this example:
<directory>\Circuits\Hardware_in_the_Loop\To_be_completed/DMI_Arduino

3. Click on Device Parameters and define two new parameters as in the image:
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Device Parameters

« Specify the Device parameters

Enter number of parameters 2

Parameter Name  Parameter Default Parameter Description
Type Value

BAUDRATE double 9600

COMPORT string | COM4 :

OK Cancel Apply

4. Click Apply and OK.

5. Click OK and generate all the files. Automatically a new folder called
ArduinoHILDemo1 (Part Name) is included in

<directory>\Circuits\Hardware_in_the_Loop\To_be_completed/DMI_Arduino
with another two folders: code and lib.

code
lib

In the code folder you will find the files to be used in Visual Studio to generate the
DLL:

ArduinoHILDemol.log
I3 ArduinoHILDemol.vcxproj
[J ArduinoHILDemo1_user.cpp
[J pspArduinoHILDemol.cpp
[ pspArduinoHILDemol.h
] pspEngFunc.cpp
[ pspEngFunch
[5 PSpiceBaseh
[ PSpiceCMIApiDefsh
[ PSpiceCommonAPIDefs.h
[ PSpiceDigApiDefsh
(3 stdAfx.cpp
B StdAfxh

In Lib folder you will find the PSpice Model:
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= ArduinoHILDemol.lib
g inputjson

NOTE: The DLL will be generated when all the files are compiled in VS.
6. Include inside of the folder

<directory>Circuits\Hardware_in_the_Loop\To_be_completed\DMI_Arduino\ArduinoH
ILDemo1\code

the files, which allow the USB Serial transmission of data. They are located in

<directory>Circuits/Hardware_in_the_Loop/To_be_completed/USB_Serial_Protocol

0O CSerial.cpp
[ CSerial.h

7. Open Visual Studio Community 2013 and click on File->Open->Project/Solution to
load the project:

»q Open Project 52

@Uv « To_be_completed » DMI_Arduino » ArduinoHILDemol » code - hy" code durchsucher el

Organisieren = Neuer Ordner = | &

& OneDrive & Name ¥ Anderungsdatum
<» Zuletzt besucht

3 ArduinoHILDemo1l.vexproj 21.06.2016 15:07 VC++ Project 8 KE

-.| Bibliotheken
=, Bilder
‘. Dokumente =
4. Musik
B videos

& Computer
& Windows7_0S (C)
w Data2 (Dv)
& support (\\dc01) ( _ m

-
Options: () Add to Solution
@) Close Solution

Dateiname: ArduinoHILDemol.vexproj b :AII Project Files (*.sin;*.dsw;* =

Offnen | | Abbrechen

8. On the solution Explorer Tab select ArduinoHILDemo1, click RMB - Add - Existing
Item and look for the USB Serial Protocol Files.

Application Note
Virtual Prototyping in PSpice Page 63 of 80



FlowCAD

Application Note

souton Expiorer = [
@ o--@ &=
Search Solution Explorer (Ctrl+0
1] Solution 'ArduinoHILDemol’ (1 project)
4 [ ArduinoHILDama
P ;& External D & Build
b *+ ArduinoHI Rebuild
P *+ CSerial.cpj Clean
b B CSerialh Vi .
b *+ pspArduin Lo
b B pspArduin Analyze L
b *+ pspEngFur Project Only >
> B pspEngFur Scope to This
b B PSpiceBas 3 N ) :
b B PSpiceCM] ew Solution Explorer View
b B PSpiceCor Profile Guided Optimization >
b B PSpiceDig Build Dependencies >
++ StdAfx.cprp
b B StdAfch Add * | ‘O Newltem.. Ctrl+Shift+A
B* Class Wizard... Ctrl+Shift+X ‘a Eﬁisting Item.. Shift+Alt+A
M Manage NuGet Packages... - New Filter
£}  Set as StartUp Project References...
iy, ' % Class.
Y = OEmors | &b Cut Ctrl+X
Description Paste Ctri+V File
X  Remove Del
L3 Rename
Unload Project
Rescan Solution
c Open Folder in File Explorer
&  Properties Alt+Enter

9. Select CSerial.cpp and CSerial.h and click Add.

10. Open next files and compare them with the completed ones that are located in
<directory>/Completed/DMI_Arduino in order to analyse the code that was added.
These files define the working of the model and internal configuration of the code so
that the dll works properly using the interface. (Optional).

- ArduinoHILDemo1_user.cpp
- pspArduinoHILDemo1.cpp
- pspArduinoHILDemo1.h

11. Now that you know the differences in terms of code among these files, go to the
directory

<directory>\Circuits\Hardware_in_the_Loop\Completed\DMI_Arduino\ArduinoHILDem
o1\code

copy the files that you can see in point 10 and add them in

<directory>\Circuits\Hardware_in_the_Loop\To_be_completed\DMI_Arduino\Arduino
HILDemo1\code

replacing those you have created previously.
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12. Open Visual Studio again and select Release and x64 from the top of the window:

ANALYZE WINDOW  HELP

~ Release ~ |x64 v ‘p

13. Click on Build—->Build Solution and generate DLL:

1>

----- Build started: Project: ArduinoHILDemol, Configuration: Release x64 ------

ArduinoHILDemol_user.cpp

1>ArduinoHILDemol_user.cpp(52): warning C4267: 'argument' : conversion from ‘size_t' to 'int', possible loss of data

1>
1>
1>
1>
1>
1>
1>
1>

CSerial.cpp
pspArduinoHILDemol. cpp
pspEngFunc.cpp
StdAfx.cpp
Creating library D:\PSpice\Application Notes\FlowCAD_AN_Device_Modeling_Interface\Circuits\Hardware_in_the_Loc
Generating code
Finished generating code
ArduinoHILDemol.vcxproj -»> D:\PSpice\Application Notes\FlowCAD_AN_Device_Modeling_Interface\Circuits\Hardware_in_

m=sss=s==== Build: 1 succeeded, @ failed, @ up-to-date, @ skipped ==========

14. Install Arduino IDE in your computer downloading the software from the official
Homepage:

https://www.arduino.cc/en/Main/Software

15. Open the Arduino Code located in
<directory>Circuits\Hardware_in_the_Loop\To_be_completed\Arduino_Code\Exampl

e

Name

Example.ino

16. Connect the Arduino Board with the USB Cable.

17. Click on Tools and make sure that the Port, where the Arduino Board is connected is
selected to COM4.

Sketch (Tools| Help

Auto Format Strg+T
Archive Sketch
Fix Encoding & Reload
—— Serial Monitor Strg+Umschalt+M | _____
Serial Plotter Strg+Umschalt+L
putStri Board: "Arduino/Genuino Uno” i
ti;gg\:: Port: "COM4 (Arduino/Genuino Uno)” ) Serial ports
; ) COM3
tempSe i LIRS L ! v COM4 (Arduino/Genuino Uno)
ledSer Burn Bootloader h

tiltSénsorrin = ©7
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18. Upload the code in the Arduino Board clicking on Sketch - Upload:

Sketch| Tools Help

Verify/Compile Strg+R

Upload Strg+U

Upload Using Programmer Strg+Umschalt+U
Export compiled Binary Strg+Alt+S

Show Sketch Folder Strg+K
Include Library »
Add File...

19. If everything works well, you will see the LED, the pin L and the pin ON turned on.

In Arduino software something like that is shown:

20. Design the Hardware to be simulated:

e
LM ARDUINO

. —
. MADE IN ALY
»
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Hardware connection schematic:

VGG

]. = | us

Tilt_sensor GND 1—]

10k Temp_Sensor

Arduino THO U1t LOR

AD

O— b7 T
O—— D6 A4 —0O
O—— D5 a5 —0

R4
10k

ArduinoBaoard

21. Open OrCAD Capture

22. Select Allegro Design Entry CIS or OrCAD PSpice Designer Plus:
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Cadence Product Choices

Please selectthe suite from which to check out the OrCAD Capture feature:

OrCAD Capture -
OrCAD PSpice Designer

OrCAD PCE Designer Professional ‘
OrCAD PCB Designer Professional w/PSpice
OrCAD_Capture_CIS_option with Capture

OrCAD_Capture_CIS_option with OrCAD PCE Designer Profession:

OrCAD_Capture_CIS_option with OrCAD PCE Designer Profession:

g Y gl LU suskiss skl O AT D e ia s D e aisusn

| 4 (L} ¢

| |Use as default

23. Open the project located in
<directory>\Circuits\Hardware_in_the_Loop\To_be_completed\Circuit\ArduinoHiL.opj

Cancel

U1l
Noisk 1 Tem[; 0/’
—| NOISY_INPUT - OUTPUT }—

D1

LED

1
Dbreak

Move

AN
R1 /L
W uT
10
—3 - u10
10uf ARL
10 =
T
=L
>0

MATLAB_AVGFILTER

R3
16

(=3

Light_Detector

As you can see, everything is defined except the Arduino component.

24. Open Model Editor from PSpice Utilities:

Application Note

Virtual Prototyping in PSpice

Page 68 of 80




FlowCAD

Application Note

| Cadence Release 17.2-2016
g?J.) License Client Configuration Utility
| Allegro EDM Products
| Allegro Products
| Allegro Sigrity Products
| Documentation
| OrCAD Lite Products
| OrCAD Products
I Product Utilities
| PCB Editor Utilities
| PSpice Utilities
& Magnetic Parts Editor
Model Editor N
[A] simulation Manager
Stimulus Editor

25. Click on File > Open and load the library that was created automatically when you
defined the Arduino component using DMI Template Code Generator. It should be

placed in
<directory>\Circuits\Hardware_in_the_Loop\To_be_completed\DMI_Arduino\Arduino

HILDemo1\Lib

ﬂArduinoH!LDemol.Iib:Ardu:’noHILDemcl - PSpice Model Editor - [Model Text] o@ =
. = = ®
& w N W cadence AE
LEdESE R ROD @
Models List ] .subckt ArduinoHILDemol Inputl Input2 Outputl Output2 PARAMS:
: : inst BAUDRATE=9600 inst COMPORT="COM4" mod MaxStepSize=le+30
Model Nz Eeslvoe i Moditied Date/Time ¥1 Inputl Input2 Outputl Output2 CMI ArduinoHILDemol.dll
ArduinoHIL..  SUBCKT ArduinoHILDemol model PARAMS: BAUDRATE={inst_ BAUDRATE}
COMPORT={inst_COMPORT}
.model ArduinoHILDemol model CMI ArduinoHILDemol MaxStepSize=
{mod MaxStepSize}
.ends
x Pn‘FO] [urPrmDes‘igner% starting server -
¢ [info] [orPrmDesigner] package require orPrmaspBase
Info] [orPrmDesigner] package require orPrmDirMap
tIn‘Foi tor?rmoesigneri package require orPrmRequestDispatcher
§ info] [orPrmpesigner] Loading done =
=
Z ModelEd> =
Ready NUM

26. Modify the description introducing the information that is available in the file
“Change_Me” located in

<directory>\Circuits\Hardware_in_the_Loop\To_be_completed\DMI_Arduino
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Copy and paste the whole data in your PSpice Model
[ ArduinchilDemol.lib:ArduinoHILDemol - PSpice Model Editor - [Model Text] o[B8 &=
E + . - [T e cadence° el x
LEdeal Bk RO o
Models List [8] || -subckt ArduinoHILDemol D13 D12 D11 D10 D9 D8 D7 D6 D5 D4 D3 D2 D1 DO AS A4 A3
Model Na... Type Modified PR

ArduinoHIL..  SUBCKT

27. Save.

+ PARAMS: inst BAUDRATE=9600 inst COMPORT="COM4" mod MaxStepSize=le+30
¥1 D10 0 A1 0 A0 D8 0 CMI ArduinoHILDemol.dll ArduinoHILDemol model PARARMS:

BAUDRATE={inst_ BAUDRATE} COMPCRT={inst COMPCRT}

*Y1l D10 0 Al X CMI ArduincHILDemol.dll ArduinoHILDemol model PARAMS: BAUDRATE=
{inst_BAUDRATE} COMPORT={inst_COMPORT}
.model ArduinoHILDemol model CMI ArduinoHILDemol MaxStepSize={mod MaxStepSize}

RD13
RD12
RD11
RD10
RDO9
RDOB
RDO7
RDOE
RDOS
RDO4
RDO3
RDO2
RDO1
RDOO
RAS
RE4
RA3
RAZ
RAl
RAD
*RX
.end

D1
D1
D1
D1
D9
D8
D7
D6
D5
D4
D3
D2
D1
D0
A5
A4
A3
A2
Al
R0

]

3016
2016
1016
001G
16
16
16
16
16

coocooocooo0O0O
=
(]

28. With Model Editor opened, click on File > Export to Part Library to generate the
symbol (.olb), which is being placed in the schematic:

29. Click on OK

m Edit View Model Plot Tools

(%}

=

d

New Ctri+N
Open... Ctrl+O
Close

Save Ctrl+S
Save As...

Print... Ctrl+P

Page Setup...

Export To Part Library...

Model Import Wizard...

Encrypt Library

1 arduinohildemol.lib

2 ArduinoHILDemol.lib

3 arduinohildemol.lib

4 N:\tmp_roberto\..\MURS320.lib
5 arduinohildemol.lib

6 arduinohildemol.lib

Exit
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Create Parts for Library &3

Enter Input Model Librany:
p\Completed\CircuitiLibranACapture\arduinohildemo lib { B ]

Enter Output Part Librany:
hWCompleted\CircuitiLibranACapture\arduinohildemol.olb [ Browse... ]

Iﬂ OK ‘ [ Cancel ‘ [ Help ]

30. Now that your Symbol has been created, open OrCAD Capture and place it. But do
NOT take the symbol you have just created, but the symbol located in

<directory>\Circuits\Hardware_in_the_Loop\To_be_completed\Circuit\Library\Capture
as | have reorganized the pins position.
a. Click on Place » Part

SIAnaIysis PSpice £

| & Part... P
PSpice Componel%... »

1 \Alirn A

b. Click on Add Library
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Place Part r X

Part: & @

Part List

0402CS-10N/COILCRAFT
0402CS-1TN/COILCRAFT
0402CS-12N/COILCRAFT
0402CS-13N/COILCRAFT
0402CS-15N/COILCRAFT
0402CS-16N/COILCRAFT
0402CS-18N/COILCRAFT
0402CS-19IN/COILCRAFT |

1| »

Libraries:

Packaging
Parts per Pkg: 1

Part: -

Type:

@) Normal Convert

Search for Part

c. Select Arduino.OLB and place it making double click on the component. When
it is placed, click on H to mirror horizontally and connect it with the pins:

: Me 1 /
iplsize UR, , UT2 NOISY_INPUT- - OUTPUT Tem

MATLAB_AVGFILTER

LED Light_Detector

d. As you have placed an Arduino Symbol without an associated PSpice Model,
select the Symbol you have just placed and click RMB:
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;s;omate_PSploe Model 1}
tPSpice b MOI
]_' S [
; Connect to Bus
‘ User Assigned Reference 4
e. Click Yes and a windows pops up:
Model Import Wizard : Select Matching IEI

Select library to pick matching models

lD:\nemp\Circuim\Hardware_in_he_Locp\Complened\Circuiﬂ,Library\Capmre\arduinclildemm.Iib v| |

Model: ARDUINOHILDEMO1 Part: U112
= Arduino UNO
|| Show All
Matching Models = D13 —
ONOAILOEROT 811 —
— AQ D1Q p——
— A1 D9 ——
L — A2 D8 —
i — A3 DT —
— A4 D6 —
— A5 DS [—
D4 —
e D3f—
D2 —
D1f—
Do—
View Model Zuri Weiter> | | Abbrechen | [ Hife
f. Click Next:

Model Import Wizard : Define Pin Mapping $x
For each model inal. iate a symbol pin. The optional model inals may be left iated.
Use "View Model Text” button to view the model definition.

Model: ARDUINOHILDEMO1 Part Uiz
o rdui
__|Show Invisible Symbol Power Pins AROANO
Model Terminal Symbol Pin - D13 F——
ik} D12 —
D11 ——
D12 = — AD Dég —
E — 1ai L
D11 — 1o D8 —
D10 — a3 07—
D9 — A4 D6 [——
. Ds ——
08 B B —
e =
D6 b1 —
D5 Do f—
m -

| <zuwick || Ferigstelilen | | Abbrechen | | il

3

g. Associate each Model Terminal yith the corresponding Symbol PIN:
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Model Import Wizard : Define Pin Mapping il
For each model terminal, associate a symbol pin. The optional model terminals may be left unassociated.
Use "View Model Text” button to view the model definition.
Model : ARDUINOHILDEMO1 Part:  U12
ot : Arduino UNO
Show Invisible Symbol Power Pins
Model Terminal Symbol Pin o D13 |—

T D12 —
D8 |D8 D17
D7 |D7 — AD D10 |—

t — A1 D9 ——
D6 |D6 | —{ A2 D§ ——
D5 \D5 E — A3 DY ——
D4 D4 — A4 D6 ——
D3 D3 = | —
D2 _jn2 D
D1 D1 Dl
DO Do v DO ——
< 1 b

View Model | <zuiick | Ferigstelien Abbrechen | [ Hi

T

h. Click on Fertig and next Windows pops up:

Associate PSpice Model | 3|

‘Would you like to associate PSpice model only to the selected partinstance, or all partinstances of the
same source package in the design?

[ Update Current ] I Update All ] [ Cancel ] [ Help ]

i. Click on Update All and OK

OrCAD Capture 22|

o INFO(ORCAP-1786): PSpice model ""ARDUINOHILDEMO1™"
¥ attached successfully to part(s) “"U12"".

o]

31. Now you are ready to define the Simulation Profile. Click on New Simulation with the
name Trans and click on Create:

-Flz 0z 4% 4 4

New Simulation Profile k

AGET [ Wi
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New Simulation &2}
Name:
Trans
Cancel
Inherit Fram:

none v l E]

Root Schematic. ~ SCHEMATIC1

32. Define a Time Domain Simulation and fill in the options with the next values:

ﬂ Simulation Settings - Trans

| General | Analysis | Configuration Files | Options | Data Collection | Probe Window|
Analysis type:
- Iil
ITime Domain (Transient) ﬂ Bom 1 me; i =sEencs (IS T
S Start saving data after. |lJ seconds
Options:
@ General Settings Transient options
[IMonte Carlo/Worst Case Maximum step size: |1 m seconds

[IParametric Sweep
[ Temperature (Sweep)
[]Save Bias Point
[Load Bias Point
[]Save Check Points
[]Restart Simulation

[ Skip the initial transient bias point calculation (SKIPBP)

[~ Runin resume mode Output File O

x|

ptions...

[ ok ][ Abbrechen | Ubemenmen

33. Click on Configuration Files, select Library and add the PSpice Model for the filter and

the Arduino Board:

Q Simulation Settings - Trans

- Analysis | Configuration Files | Options | Data Collection | Probe Window |

Category:

1=

Details

B
I

Stimulus
Include

[¥ Update Index

Configured Files X = =l

| Browse... |

.\Iibrary\capme\arduinol_'nildemo1.lib Add as Global |
[£¥] Mlibrary\capture\matlab.lib

4 1 L

Library Path

@ rnomlib Add to Design |
Add to Profile I

Edit

Change |

['C\Cadence\SPB_172\tools\PSpice|Library” Browse... |

OK H Abbrechen l Ubernehmen

Hilfe
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Your library for the Arduino Board is in

<directory>\Circuits\Hardware_in_the_Loop\To_be_completed\DMI_Arduino\A

rduinoHILDemo1\lib

The library for the Matlab Filter is in

<directory>\Circuits\Hardware_in_the_Loop\To_be_completed\Circuit\Library\

Capture

34. Click on Probe Window and select the next configuration:

% Simulation Settings - Trans

| General IAnaIysis |Conﬁguralion Files | Options | Data Collection Probe Window |

[~ Display Probe window when profile is opened.

[v Display Probe window:
(@ during simulation.

(" after simulation has completed.

Show

(@ All markers on open schematics.
(" Lastplot

(" Nothing.

0K | Abbrechen | [ Ubemehmen

35. Click on OK.

36. In the Schematic click on PSpice - Markers - Voltage Level

m Accessories Options Window Help

Hilfe

=1 New Simulation Profile ¥ [l E;J m —{E @
Edit Simulation Profile :
© Run F11
View Simulation Results  F12 @
View Output File
Create Netlist T
View Netlist 100 p
Advanced Analysis 4
Markers #3 Voltage Level
Bias Points » 4 Voltage Differential
#8 Current Into Pin Bisy_In
r_ an o~ ~ - . an

and place this marker as in the image:
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= }_ﬂ

NOISY_INPUT OUTPUT

MATLAB_AVGFILTER

od

37. Before you can simulate Hardware in the Loop, you have to place the DLL’s in the
PSpice Simulation Settings Folder you have just created. Copy your DLL located in

<directory>\Circuits\Hardware_in_the_Loop\To_be_completed\DMI_Arduino\Arduino
HILDemo1\code\x64\Release\ArduinoHILDemo1.dll

and pastitin

<directory>Circuits\Hardware_in_the_Loop\To_be_completed\Circuit\ArduinoHiL-
PSpiceFiles\SCHEMATIC1\Trans

38. Do the same with the DLL for the Matlab Filter located in
<directory>\Circuits\Hardware_in_the _Loop\To_be_completed\Circuit\Library\DLL

39. Now connect the hardware to the computer (if it is not already connected) and click
on Run Simulation:

»_PWMCONTRC

o QE 844

NOTE: If you get a Netlisting Error, you have to connect all the unconnected pins
together.

Application Note
Virtual Prototyping in PSpice Page 77 of 80



FlowCAD

Application Note

usa Zrduino UNO

D13
D12
D11

|

D10 AD

D9
D8
D7
D6
D5
D4
D3
D2
D1
Do

Al
A2
A3
Ad
A5

N =

Move

R2
1G

2

Arduino

40. When the Probe Window opens, click on Tools > Options and select Auto-Update

Intervals as in the image.

Probe Settings

General jLarge Data File | Cursor Settings | Color Settings FontSelﬁngs:

Use Symbols Trace Color Scheme )
Mark Data Points
Properties @ Normal
- bhench A || Display Evaluation
Q) Always Sequential Per Axis (V| Display Statistics
Unique By File |/ | Highlight Error States
Use ScrollBars Auto-Update Intervals
@) Auto Auto
Never Every 1 sec
Always Q@ Every 1 %
10 Number of Histogram Divisions
1 Default Trace Width
| OK l l Abbrechen l | Reset l

L

41. Test the simulation HiL moving the board, incrementing the
varying the amount of received light:

sensor temperature or
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NOTE: Move the voltage Marker you placed to the different nodes to visualize the
different results.

- Temperature Sensor:

I M M%vmw W WWW"WWW

- Light Sensor:

peorase e s

- Tilt Sensor:
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